aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/imake/Makefile2
-rw-r--r--devel/imake/distinfo5
-rw-r--r--devel/imake/files/patch-xmkmf.cpp26
-rw-r--r--devel/imake/pkg-descr3
-rw-r--r--devel/libpciaccess/Makefile4
-rw-r--r--devel/libpciaccess/distinfo5
-rw-r--r--devel/libpciaccess/pkg-descr3
-rw-r--r--devel/makedepend/Makefile2
-rw-r--r--devel/makedepend/distinfo5
-rw-r--r--devel/makedepend/pkg-descr2
-rw-r--r--devel/xorg-macros/Makefile2
-rw-r--r--devel/xorg-macros/distinfo5
-rw-r--r--devel/xorg-macros/pkg-descr3
13 files changed, 42 insertions, 25 deletions
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index b2aba137837e..fa9ac23f4f43 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= imake
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
PORTEPOCH= 1
CATEGORIES= devel
diff --git a/devel/imake/distinfo b/devel/imake/distinfo
index 393b5982e730..1e2fe2cdcd7d 100644
--- a/devel/imake/distinfo
+++ b/devel/imake/distinfo
@@ -1,3 +1,2 @@
-MD5 (xorg/util/imake-1.0.3.tar.bz2) = ff553c4646edcc9e76b7308991ad421a
-SHA256 (xorg/util/imake-1.0.3.tar.bz2) = 90015244dd7a32594162d2be6e934a258894d1ca2c37422ef727a7f1c0b553ea
-SIZE (xorg/util/imake-1.0.3.tar.bz2) = 139230
+SHA256 (xorg/util/imake-1.0.4.tar.bz2) = acb27ff09e3083000441a8d555fbedbf35ecb4ad52d2bd5b8680dce853f146fe
+SIZE (xorg/util/imake-1.0.4.tar.bz2) = 140773
diff --git a/devel/imake/files/patch-xmkmf.cpp b/devel/imake/files/patch-xmkmf.cpp
new file mode 100644
index 000000000000..a08866e3855f
--- /dev/null
+++ b/devel/imake/files/patch-xmkmf.cpp
@@ -0,0 +1,26 @@
+--- work/imake-1.0.2/xmkmf.cpp 2004-04-23 18:42:00.000000000 +0000
++++ xmkmf.cpp 2009-12-14 20:51:01.695597560 +0000
+@@ -53,6 +53,10 @@
+ args="-I$topdir/config/cf -DTOPDIR=$topdir -DCURDIR=$curdir"
+ fi
+
++if [ -n "$CPP" -a -z "$IMAKECPP" ];then
++ export IMAKECPP=$CPP
++fi
++
+ echo imake $imake_defines $args
+ case "$do_all" in
+ yes)
+@@ -68,3 +72,12 @@
+ imake $imake_defines $args
+ ;;
+ esac
++
++if [ -f "Makefile" ];then
++ if [ -n "$CC" ];then
++ sed -i "" -e "s| CC = cc| CC = $CC|" Makefile
++ fi
++ if [ -n "$CXX" ];then
++ sed -i "" -e "s| CXX = c++| CXX = $CXX|" Makefile
++ fi
++fi
diff --git a/devel/imake/pkg-descr b/devel/imake/pkg-descr
index aa426ccf2e28..18425ed4eb59 100644
--- a/devel/imake/pkg-descr
+++ b/devel/imake/pkg-descr
@@ -2,6 +2,3 @@ This package contains X.Org's imake, imake config files, and other build-related
tools.
WWW: http://www.x.org/
-
-- Eric Anholt
-anholt@FreeBSD.org
diff --git a/devel/libpciaccess/Makefile b/devel/libpciaccess/Makefile
index e8f5676a5494..3954d510716c 100644
--- a/devel/libpciaccess/Makefile
+++ b/devel/libpciaccess/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libpciaccess
-PORTVERSION= 0.12.0
+PORTVERSION= 0.12.1
CATEGORIES= devel
MAINTAINER= x11@FreeBSD.org
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/share/pciids/pci.ids:${PORTSDIR}/misc/pciids
# XXX - Is it a runtime dep too?
RUN_DEPENDS= ${LOCALBASE}/share/pciids/pci.ids:${PORTSDIR}/misc/pciids
-CONFIGURE_ARGS= --with-pciids-path=${LOCALBASE}/share/pciids
+CONFIGURE_ARGS+= --with-pciids-path=${LOCALBASE}/share/pciids
XORG_CAT= lib
diff --git a/devel/libpciaccess/distinfo b/devel/libpciaccess/distinfo
index 985e1c1e94ff..dd572d7b7e77 100644
--- a/devel/libpciaccess/distinfo
+++ b/devel/libpciaccess/distinfo
@@ -1,3 +1,2 @@
-MD5 (xorg/lib/libpciaccess-0.12.0.tar.bz2) = 285e07976274572e1f1e68edee09b70a
-SHA256 (xorg/lib/libpciaccess-0.12.0.tar.bz2) = f6b3c00e1c0aab0729563115d3d798e14c9210b4e10fccb484efe1c5eae85657
-SIZE (xorg/lib/libpciaccess-0.12.0.tar.bz2) = 294535
+SHA256 (xorg/lib/libpciaccess-0.12.1.tar.bz2) = cc47d7f0e48cf4eed972916b536fdc97788d7521915e3ae1cc92d540776d7344
+SIZE (xorg/lib/libpciaccess-0.12.1.tar.bz2) = 326217
diff --git a/devel/libpciaccess/pkg-descr b/devel/libpciaccess/pkg-descr
index 77dbb5584df9..a095db27f052 100644
--- a/devel/libpciaccess/pkg-descr
+++ b/devel/libpciaccess/pkg-descr
@@ -1,6 +1,3 @@
This package contains the pciaccess library.
WWW: http://www.freedesktop.org/Software/xlibs
-
-- Florent Thoumie
-flz@FreeBSD.org
diff --git a/devel/makedepend/Makefile b/devel/makedepend/Makefile
index e2a161be0bf3..4f6e0f8b2762 100644
--- a/devel/makedepend/Makefile
+++ b/devel/makedepend/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= makedepend
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
PORTEPOCH= 1
CATEGORIES= devel
diff --git a/devel/makedepend/distinfo b/devel/makedepend/distinfo
index 874d304632a6..5fce726c8432 100644
--- a/devel/makedepend/distinfo
+++ b/devel/makedepend/distinfo
@@ -1,3 +1,2 @@
-MD5 (xorg/util/makedepend-1.0.2.tar.bz2) = 62e58330fe8d1e3e28c7a45779833a48
-SHA256 (xorg/util/makedepend-1.0.2.tar.bz2) = 41a2b090a32d7c5b2654783772248aba472702686e30018cfd9907137a967657
-SIZE (xorg/util/makedepend-1.0.2.tar.bz2) = 116339
+SHA256 (xorg/util/makedepend-1.0.3.tar.bz2) = 3a251d30e567e4eab109be486918887635e08963195b80d193f0ee65cef8b737
+SIZE (xorg/util/makedepend-1.0.3.tar.bz2) = 123703
diff --git a/devel/makedepend/pkg-descr b/devel/makedepend/pkg-descr
index 09295054d53b..5470aec145e4 100644
--- a/devel/makedepend/pkg-descr
+++ b/devel/makedepend/pkg-descr
@@ -12,3 +12,5 @@ Every file that a sourcefile includes, directly or indirectly, is what
makedepend calls a "dependency". These dependencies are then written to a
makefile in such a way that make will know which object files must be
recompiled when a dependency has changed.
+
+WWW: http://www.x.org/archive/X11R7.5/doc/man/man1/makedepend.1.html \ No newline at end of file
diff --git a/devel/xorg-macros/Makefile b/devel/xorg-macros/Makefile
index 46c3489bf171..94ffab8e6333 100644
--- a/devel/xorg-macros/Makefile
+++ b/devel/xorg-macros/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xorg-macros
-PORTVERSION= 1.6.0
+PORTVERSION= 1.11.0
CATEGORIES= devel x11
DISTNAME= util-macros-$(PORTVERSION)
diff --git a/devel/xorg-macros/distinfo b/devel/xorg-macros/distinfo
index b1741d48bc33..d417cd364311 100644
--- a/devel/xorg-macros/distinfo
+++ b/devel/xorg-macros/distinfo
@@ -1,3 +1,2 @@
-MD5 (xorg/util/util-macros-1.6.0.tar.bz2) = 6a0ac8efb11ad9b867f2e08ef87ad4c4
-SHA256 (xorg/util/util-macros-1.6.0.tar.bz2) = 9d074937d3187f3c776e09a762ea996e0ca28e9784bac57de27d36f9b6955cd1
-SIZE (xorg/util/util-macros-1.6.0.tar.bz2) = 61264
+SHA256 (xorg/util/util-macros-1.11.0.tar.bz2) = e8534d56a4f8475acecee1c9faf5193340a80785f2c80858fd233595cb3fcacf
+SIZE (xorg/util/util-macros-1.11.0.tar.bz2) = 67786
diff --git a/devel/xorg-macros/pkg-descr b/devel/xorg-macros/pkg-descr
index bddd7c8c689e..1a4b4bbe8b01 100644
--- a/devel/xorg-macros/pkg-descr
+++ b/devel/xorg-macros/pkg-descr
@@ -1,5 +1,4 @@
This package contains the aclocal macros needed for building xorg modules
from upstream source.
-- Eric Anholt
-anholt@FreeBSD.org
+WWW: http://cgit.freedesktop.org/xorg/util/macros/