aboutsummaryrefslogtreecommitdiff
path: root/dns/bind912/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/bind912/Makefile')
-rw-r--r--dns/bind912/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/dns/bind912/Makefile b/dns/bind912/Makefile
index 66700eeeee66..196f7c4ab0de 100644
--- a/dns/bind912/Makefile
+++ b/dns/bind912/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bind
PORTVERSION= ${ISCVERSION:S/-P/P/:S/b/.b/:S/a/.a/:S/rc/.rc/}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns net ipv6
MASTER_SITES= ISC/bind9/${ISCVERSION}
PKGNAMESUFFIX= 912
@@ -19,6 +19,7 @@ DEPRECATED= Support ends, please move to dns/bind914.
EXPIRATION_DATE= 2019-05-31
LIB_DEPENDS= libxml2.so:textproc/libxml2
+RUN_DEPENDS= bind-tools>0:dns/bind-tools
USES= compiler:c11 cpe libedit
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
@@ -37,10 +38,11 @@ CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-readline="-L${LOCALBASE}/lib -ledit" \
--with-dlopen=yes \
--with-gost=no \
+ --without-python \
--sysconfdir=${ETCDIR}
ETCDIR= ${PREFIX}/etc/namedb
-CONFLICTS= bind911 bind913 bind914 bind9-devel bind-tools
+CONFLICTS= bind911 bind913 bind914 bind9-devel
USE_RC_SUBR= named
SUB_FILES= pkg-message named.conf
@@ -49,9 +51,9 @@ PORTDOCS= *
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON PYTHON \
+OPTIONS_DEFAULT= SSL THREADS SIGCHASE IDN GSSAPI_NONE JSON \
DLZ_FILESYSTEM LMDB RPZ_NSDNAME RPZ_NSIP TCP_FASTOPEN
-OPTIONS_DEFINE= IDN LARGE_FILE PYTHON JSON \
+OPTIONS_DEFINE= IDN LARGE_FILE JSON \
FIXED_RRSET SIGCHASE IPV6 THREADS \
RPZ_NSIP RPZ_NSDNAME DOCS \
MINCACHE PORTREVISION QUERYTRACE LMDB DNSTAP \
@@ -87,7 +89,6 @@ LMDB_DESC= Use LMDB for zone management
MINCACHE_DESC= Use the mincachettl patch
NATIVE_PKCS11_DESC= Use PKCS\#11 native API (**READ HELP**)
PORTREVISION_DESC= Show PORTREVISION in the version string
-PYTHON_DESC= Build with Python utilities
QUERYTRACE_DESC= Enable the very verbose query tracelogging
RPZ_NSDNAME_DESC= Enable RPZ NSDNAME policy records
RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
@@ -155,11 +156,6 @@ MINCACHE_EXTRA_PATCHES= ${FILESDIR}/extrapatch-bind-min-override-ttl
NATIVE_PKCS11_CONFIGURE_ENABLE= native-pkcs11
NATIVE_PKCS11_IMPLIES= THREADS
-PYTHON_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${PY_FLAVOR}
-PYTHON_CONFIGURE_WITH= python=${PYTHON_CMD}
-PYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${PY_FLAVOR}
-PYTHON_USES= python
-
QUERYTRACE_CONFIGURE_ENABLE= querytrace
RPZ_NSDNAME_CONFIGURE_ENABLE= rpz-nsdname
@@ -248,8 +244,4 @@ post-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/CHANGES* ${WRKSRC}/HISTORY.md \
${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
-# Can't use USE_PYTHON=autoplist
-post-install-PYTHON-on:
- @${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -type f | ${SED} -e 's|${STAGEDIR}||' >> ${TMPPLIST}
-
.include <bsd.port.post.mk>