aboutsummaryrefslogtreecommitdiff
path: root/dns/knock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/knock/Makefile')
-rw-r--r--dns/knock/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/dns/knock/Makefile b/dns/knock/Makefile
index 18596be5f942..7ab54895e1c3 100644
--- a/dns/knock/Makefile
+++ b/dns/knock/Makefile
@@ -1,6 +1,5 @@
PORTNAME= knock
-DISTVERSION= 4.1.0-27
-DISTVERSIONSUFFIX= -ge2c98df
+DISTVERSION= 5.1.0
CATEGORIES= dns
PKGNAMESUFFIX= py
@@ -9,14 +8,24 @@ COMMENT= Tool designed to enumerate subdomains on a target domain
LICENSE= GPLv2
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython@${PY_FLAVOR}
+PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colorama>0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
+BUILD_DEPENDS= ${PY_DEPENDS}
+RUN_DEPENDS= ${PY_DEPENDS}
+
+USES= python pyqt:5 # pyqt:5 isn't used: https://github.com/guelfoweb/knock/issues/108
+USE_PYTHON= distutils noflavors autoplist
+USE_PYQT= core_run
-USES= python
USE_GITHUB= yes
GH_ACCOUNT= guelfoweb
-USE_PYTHON= distutils noflavors autoplist
NO_ARCH= yes
+post-install: # workaround for: pkg_resources.DistributionNotFound: The 'PyQt5' distribution was not found and is required by knockpy
+ @${REINPLACE_CMD} -e 's|PyQt5||' ${STAGEDIR}/${PYTHON_SITELIBDIR}/*/requires.txt
+
.include <bsd.port.mk>