aboutsummaryrefslogtreecommitdiff
path: root/editors/code-browser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/code-browser/Makefile')
-rw-r--r--editors/code-browser/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/editors/code-browser/Makefile b/editors/code-browser/Makefile
new file mode 100644
index 000000000000..12fbed621b58
--- /dev/null
+++ b/editors/code-browser/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: code-browser
+# Date created: Jan 25, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= code-browser
+PORTVERSION= 1.2
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Folding Text Editor
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_REINPLACE= yes
+USE_GNOME= gtk20
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/local,${PREFIX}," \
+ -e "s,^CC,#CC," -e "s,^CFLAGS,#CFLAGS," \
+ ${WRKSRC}/${MAKEFILE} ${WRKSRC}/zinc/${MAKEFILE}
+
+.include <bsd.port.mk>