aboutsummaryrefslogtreecommitdiff
path: root/editors/scite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/scite/Makefile')
-rw-r--r--editors/scite/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/editors/scite/Makefile b/editors/scite/Makefile
index c54fc35989d5..f069874d8bf7 100644
--- a/editors/scite/Makefile
+++ b/editors/scite/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= scite
-DISTVERSION= 4.0.2
-PORTREVISION= 1
+DISTVERSION= 4.1.0
CATEGORIES= editors gnome
MASTER_SITES= SF/scintilla/SciTE/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
@@ -19,11 +18,14 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libscintilla.so:x11-toolkits/scintilla
RUN_DEPENDS= xdg-open:devel/xdg-utils
+USES= compiler:c++17-lang desktop-file-utils gmake pkgconfig tar:tgz
+
OPTIONS_DEFINE= DOCS
+PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}
WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
-USES= compiler:c++14-lang desktop-file-utils gmake pkgconfig tar:tgz
+CXXSTD= c++17
USE_GNOME= cairo gdkpixbuf2 gtk20
MAKEFILE= makefile