aboutsummaryrefslogtreecommitdiff
path: root/editors/vscode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/vscode/Makefile')
-rw-r--r--editors/vscode/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/vscode/Makefile b/editors/vscode/Makefile
index 9412c1791ed1..ac0aabe9bdce 100644
--- a/editors/vscode/Makefile
+++ b/editors/vscode/Makefile
@@ -1,5 +1,5 @@
PORTNAME= vscode
-DISTVERSION= 1.55.1
+DISTVERSION= 1.55.2
CATEGORIES= editors
MASTER_SITES= https://registry.npmjs.org/esbuild-freebsd-64/-/:esbuild_binary \
https://nodejs.org/dist/v${NODE_VER}/:node_headers \
@@ -66,7 +66,7 @@ USES= desktop-file-utils gl gmake gnome jpeg pkgconfig \
USE_GITHUB= yes
GH_ACCOUNT= microsoft
-SOURCE_COMMIT_HASH= 08a217c4d27a02a5bcde898fd7981bda5b49391b
+SOURCE_COMMIT_HASH= 3c4e3df9e89829dce27b7b5c24508306b151f30d
BINARY_ALIAS= python=${PYTHON_CMD}
@@ -215,7 +215,7 @@ do-install:
cd ${WRKDIR}/VSCode-linux-x64 && \
${TAR} -cf - . | ${TAR} -xf - -C ${STAGEDIR}${DATADIR}
cd ${STAGEDIR}${DATADIR}/resources/app/node_modules.asar.unpacked && \
- ${FIND} . -type f -exec ${STRIP_CMD} {} ';'
+ ${FIND} . -type f -name '*.node' -exec ${STRIP_CMD} {} ';'
.for f in chromedriver mksnapshot v8_context_snapshot_generator
${RM} ${STAGEDIR}${DATADIR}/${f}
.endfor