aboutsummaryrefslogtreecommitdiff
path: root/emulators/libretro-bsnes
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/libretro-bsnes')
-rw-r--r--emulators/libretro-bsnes/Makefile29
-rw-r--r--emulators/libretro-bsnes/distinfo3
-rw-r--r--emulators/libretro-bsnes/pkg-descr3
3 files changed, 35 insertions, 0 deletions
diff --git a/emulators/libretro-bsnes/Makefile b/emulators/libretro-bsnes/Makefile
new file mode 100644
index 000000000000..c6869f69ddbe
--- /dev/null
+++ b/emulators/libretro-bsnes/Makefile
@@ -0,0 +1,29 @@
+# Created by: Timothy Beyer <beyert@cs.ucr.edu>
+
+PORTNAME= libretro-bsnes
+PORTVERSION= 20211218
+CATEGORIES= emulators games
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Standalone port of bSNES to libretro
+
+LICENSE= GPLv3
+
+USES= compiler:c++11-lib gmake
+
+USE_GCC= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_PROJECT= bsnes-libretro
+GH_TAGNAME= 9549275
+
+USE_LDCONFIG= yes
+
+PLIST_FILES= lib/libretro/bsnes_libretro.so
+
+do-install:
+ @${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
+ ${INSTALL_LIB} ${WRKSRC}/bsnes_libretro.so ${STAGEDIR}/${PREFIX}/lib/libretro;
+
+.include <bsd.port.mk>
diff --git a/emulators/libretro-bsnes/distinfo b/emulators/libretro-bsnes/distinfo
new file mode 100644
index 000000000000..501e0b5aecec
--- /dev/null
+++ b/emulators/libretro-bsnes/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1640163197
+SHA256 (libretro-bsnes-libretro-20211218-9549275_GH0.tar.gz) = 76f5de645b425ddd9c90085fc5d5b9309c378475e964d149aed253569fc8aa76
+SIZE (libretro-bsnes-libretro-20211218-9549275_GH0.tar.gz) = 7281394
diff --git a/emulators/libretro-bsnes/pkg-descr b/emulators/libretro-bsnes/pkg-descr
new file mode 100644
index 000000000000..a567f1cf87df
--- /dev/null
+++ b/emulators/libretro-bsnes/pkg-descr
@@ -0,0 +1,3 @@
+Standalone port of bSNES to libretro.
+
+WWW: https://github.com/libretro/bsnes-libretro