aboutsummaryrefslogtreecommitdiff
path: root/emulators/libretro-flycast/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/libretro-flycast/Makefile')
-rw-r--r--emulators/libretro-flycast/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/emulators/libretro-flycast/Makefile b/emulators/libretro-flycast/Makefile
index fe5e75d0f23f..6b4a1454ab6c 100644
--- a/emulators/libretro-flycast/Makefile
+++ b/emulators/libretro-flycast/Makefile
@@ -1,14 +1,14 @@
-# $FreeBSD$
+# Created by: Timothy Beyer <beyert@cs.ucr.edu>
PORTNAME= libretro-flycast
PORTVERSION= 0.20210608
+PORTREVISION= 1
CATEGORIES= emulators games
MAINTAINER= beyert@cs.ucr.edu
COMMENT= Standalone port of flycast to libretro
LICENSE= GPLv2
-#LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= amd64 i386
@@ -21,7 +21,7 @@ LIB_DEPENDS+= libao.so:audio/libao \
libudev.so:devel/libudev-devd \
libvulkan.so:graphics/vulkan-loader
-USES= compiler:c++11-lib dos2unix gl gmake xorg
+USES= compiler:c++11-lib dos2unix gl gmake pkgconfig xorg
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -29,7 +29,7 @@ GH_ACCOUNT= libretro
GH_PROJECT= flycast
GH_TAGNAME= 8e4fa54e
-USE_GL+= gl glew glu
+USE_GL+= egl gl glew glu
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
@@ -51,12 +51,18 @@ MAKE_ARGS= HAVE_GENERIC_JIT=0 \
MAKE_ARGS+= WITH_DYNAREC=x86_64
.elif ${ARCH} == i386
MAKE_ARGS+= WITH_DYNAREC=x86
+USE_BINUTILS= yes
+LDFLAGS+= -Wl,-z,notext
.endif
PLIST_FILES= lib/libretro/flycast_libretro.so
+post-patch:
+ @${REINPLACE_CMD} 's|/usr/local|${PREFIX}|' \
+ ${WRKSRC}/Makefile
+
do-install:
- ${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
+ @${MKDIR} ${STAGEDIR}/${PREFIX}/lib/libretro;
${INSTALL_LIB} ${WRKSRC}/flycast_libretro.so \
${STAGEDIR}/${PREFIX}/lib/libretro/flycast_libretro.so;