aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-power10-functional-sim/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux-power10-functional-sim/Makefile')
-rw-r--r--emulators/linux-power10-functional-sim/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/emulators/linux-power10-functional-sim/Makefile b/emulators/linux-power10-functional-sim/Makefile
new file mode 100644
index 000000000000..b63b7bc5b886
--- /dev/null
+++ b/emulators/linux-power10-functional-sim/Makefile
@@ -0,0 +1,31 @@
+# Created by: Kevin Bowling <kbowling@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= power10-functional-sim
+PORTVERSION= 1.0
+DISTVERSIONSUFFIX= -0.rhel7
+CATEGORIES= emulators linux
+MASTER_SITES= http://public.dhe.ibm.com/software/server/powerfuncsim/p10/packages/v1.0-0/
+
+MAINTAINER= kbowling@FreeBSD.org
+COMMENT= IBM POWER10 Functional Simulator (mambo) (CentOS ${LINUX_DIST_VER})
+
+LICENSE= IBMFUNCTIONALSIM
+LICENSE_NAME= IBM Functional Simulator License
+LICENSE_FILE= ${FILESDIR}/LA_en.txt
+LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
+
+ONLY_FOR_ARCHS= amd64
+
+USES= linux:c7 perl5 shebangfix
+SHEBANG_FILES= opt/ibm/systemsim-p10/bin/systemsim
+SHEBANG_GLOB= *.sh *.pl
+USE_LDCONFIG= yes
+USE_LINUX= tcl85
+USE_LINUX_RPM= nolib
+USE_PERL5= run
+
+BIN_DISTNAMES= systemsim-p10-${DISTVERSION}${DISTVERSIONSUFFIX}
+SRC_DISTFILES=
+
+.include <bsd.port.mk>