aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-fc4
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/linux_base-fc4')
-rw-r--r--emulators/linux_base-fc4/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/emulators/linux_base-fc4/Makefile b/emulators/linux_base-fc4/Makefile
index 0727b80f92ad..89de6b55fdac 100644
--- a/emulators/linux_base-fc4/Makefile
+++ b/emulators/linux_base-fc4/Makefile
@@ -172,11 +172,17 @@ do-build:
#
@${MV} ${WRKSRC}/etc/nsswitch.conf ${WRKSRC}/etc/nsswitch.conf.dist
+# Fix usr/bin/*db4* permissions to allow "portupgrade -s"
+ @${CHMOD} u+w ${WRKSRC}/usr/bin/*db4*
+
@${FIND} ${WRKSRC}/bin ${WRKSRC}/sbin/ ${WRKSRC}/usr/bin \
${WRKSRC}/usr/sbin -type f -print0 | ${XARGS} -0 ${FILE} \
| ${GREP} ELF | ${CUT} -d : -f 1 \
| ${XARGS} ${BRANDELF} -t Linux
+# Restore the status quo for usr/bin/*db4* files
+ @${CHMOD} u-w ${WRKSRC}/usr/bin/*db4*
+
do-install:
#
# Handle the loading of the linux loadable kernel module if required.