aboutsummaryrefslogtreecommitdiff
path: root/emulators/open-vm-tools/files
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/open-vm-tools/files')
-rw-r--r--emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in19
-rw-r--r--emulators/open-vm-tools/files/patch-wrapper-Makefile.in21
-rw-r--r--emulators/open-vm-tools/files/patch-wrapper-wrapper-freebsd.c11
3 files changed, 13 insertions, 38 deletions
diff --git a/emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in b/emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in
index 17fdf9708a2c..9d9d10a38fbd 100644
--- a/emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in
+++ b/emulators/open-vm-tools/files/patch-hgfsmounter-Makefile.in
@@ -1,15 +1,22 @@
---- hgfsmounter/Makefile.in.orig 2009-04-06 17:24:30.000000000 -0400
-+++ hgfsmounter/Makefile.in 2009-04-06 17:26:09.000000000 -0400
-@@ -569,9 +569,9 @@
+--- hgfsmounter/Makefile.in.orig 2011-09-21 18:25:50.000000000 +0000
++++ hgfsmounter/Makefile.in 2011-09-25 04:03:22.000000000 +0000
+@@ -606,14 +606,14 @@
@FREEBSD_TRUE@ mv $(DESTDIR)$(sbindir)/mount.vmhgfs \
@FREEBSD_TRUE@ $(DESTDIR)$(sbindir)/mount_vmhgfs
- @FREEBSD_TRUE@@WITH_ROOT_PRIVILEGES_TRUE@ chmod u+s $(DESTDIR)$(sbindir)/mount_vmhgfs
--@FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
+ @FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
-@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
-@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
-+#@FREEBSD_TRUE@ -$(MKDIR_P) $(DESTDIR)/sbin
+#@FREEBSD_TRUE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount_vmhgfs \
+#@FREEBSD_TRUE@ $(DESTDIR)/sbin/mount_vmhgfs &> /dev/null
@FREEBSD_TRUE@uninstall-hook:
@FREEBSD_TRUE@ rm -f $(DESTDIR)$(sbindir)/mount_vmhgfs
@FREEBSD_FALSE@install-exec-hook:
+-@FREEBSD_FALSE@ -$(MKDIR_P) $(DESTDIR)/sbin
+-@FREEBSD_FALSE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount.vmhgfs \
+-@FREEBSD_FALSE@ $(DESTDIR)/sbin/mount.vmhgfs &> /dev/null
++#@FREEBSD_FALSE@ -$(MKDIR_P) $(DESTDIR)/sbin
++#@FREEBSD_FALSE@ -$(LN_S) $(DESTDIR)$(sbindir)/mount.vmhgfs \
++#@FREEBSD_FALSE@ $(DESTDIR)/sbin/mount.vmhgfs &> /dev/null
+ @FREEBSD_FALSE@uninstall-hook:
+ @FREEBSD_FALSE@ rm -f $(DESTDIR)/sbin/mount.vmhgfs
+
diff --git a/emulators/open-vm-tools/files/patch-wrapper-Makefile.in b/emulators/open-vm-tools/files/patch-wrapper-Makefile.in
deleted file mode 100644
index ecd2355ae35b..000000000000
--- a/emulators/open-vm-tools/files/patch-wrapper-Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- vmware-user-suid-wrapper/Makefile.in.orig 2010-10-20 05:20:08.000000000 +0900
-+++ vmware-user-suid-wrapper/Makefile.in 2010-11-16 17:52:55.000000000 +0900
-@@ -301,7 +301,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--AM_CPPFLAGS = -DVMTOOLSD_PATH=\"$(bindir)/vmtoolsd\"
-+AM_CPPFLAGS = -DVMTOOLSD_PATH=\"$(bindir)/vmtoolsd\" -DVMWARE_KMOD_DIR=\"$(prefix)/lib/vmware-tools/modules/drivers\"
- vmware_user_suid_wrapper_SOURCES = main.c wrapper-@TARGET_OS@.c
- vmware_user_suid_wrapper_LDADD = ../lib/vmSignal/libVmSignal.la
- desktopfile = vmware-user.desktop
-@@ -583,7 +583,8 @@
-
- info-am:
-
--install-data-am: install-autostartDATA
-+#install-data-am: install-autostartDATA
-+install-data-am:
-
- install-dvi: install-dvi-am
-
diff --git a/emulators/open-vm-tools/files/patch-wrapper-wrapper-freebsd.c b/emulators/open-vm-tools/files/patch-wrapper-wrapper-freebsd.c
deleted file mode 100644
index c5c9d0a1fd29..000000000000
--- a/emulators/open-vm-tools/files/patch-wrapper-wrapper-freebsd.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- vmware-user-suid-wrapper/wrapper-freebsd.c.orig 2010-10-20 05:19:54.000000000 +0900
-+++ vmware-user-suid-wrapper/wrapper-freebsd.c 2010-11-16 17:52:55.000000000 +0900
-@@ -116,7 +116,7 @@
- /*
- * Kldload(2) will handle module search paths for us.
- */
-- if (kldload(MODULE_NAME) == -1) {
-+ if (kldload(VMWARE_KMOD_DIR "/" MODULE_NAME ".ko") == -1) {
- Error("failed to load vmblock: %s\n", strerror(errno));
- return FALSE;
- }