aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-legacy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/virtualbox-ose-legacy/Makefile')
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile98
1 files changed, 44 insertions, 54 deletions
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index be9897e5f61a..63d777d9f90e 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -1,6 +1,6 @@
PORTNAME= virtualbox-ose
PORTVERSION= 5.2.44
-PORTREVISION= 14
+PORTREVISION= 15
CATEGORIES= emulators
MASTER_SITES= https://download.oracle.com/virtualbox/${PORTVERSION}/
PKGNAMESUFFIX?= -legacy
@@ -14,24 +14,24 @@ WWW= https://www.virtualbox.org/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+ONLY_FOR_ARCHS= amd64 i386
+
PATCH_DEPENDS+= ${LOCALBASE}/share/kBuild/tools/GXX3.kmk:devel/kBuild
-BUILD_DEPENDS= yasm:devel/yasm \
- xsltproc:textproc/libxslt \
+BUILD_DEPENDS= gtar:archivers/gtar \
kmk:devel/kBuild \
- gtar:archivers/gtar
+ libIDL-config-2:devel/libIDL \
+ yasm:devel/yasm \
+ xsltproc:textproc/libxslt
LIB_DEPENDS= libpng.so:graphics/png \
- libxslt.so:textproc/libxslt \
libcurl.so:ftp/curl
RUN_DEPENDS= ${LOCALBASE}/etc/rc.d/vboxnet:emulators/virtualbox-ose-kmod-legacy
+USES= compiler:c++14-lang cpe gnome iconv pkgconfig ssl tar:bzip2
+USE_GNOME= libxml2
+
CPE_VENDOR= oracle
CPE_PRODUCT= vm_virtualbox
-WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
-ONLY_FOR_ARCHS= i386 amd64
-USES= compiler:c++14-lang cpe gnome iconv pkgconfig ssl tar:bzip2
-USE_GNOME= libidl libxml2
-
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --disable-java --passive-mesa
CONFIGURE_ARGS+= --with-gcc="${CC}" --with-g++="${CXX}"
@@ -41,9 +41,9 @@ CONFLICTS_INSTALL= virtualbox-ose-additions-* \
virtualbox-ose \
virtualbox-ose-lite
-PORTSCOUT= limit:^5\.
+WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
-LDFLAGS= -lpthread
+PORTSCOUT= limit:^5\.
VBOXUSER?= vboxusers
VBOXWSUSER?= vboxusers
@@ -59,20 +59,20 @@ VBOX_PROGS= VBoxAutostart VBoxBalloonCtrl VBoxBugReport VBoxHeadless \
VBOX_UTILS= VBoxExtPackHelperApp VBoxNetAdpCtl VBoxNetDHCP VBoxNetNAT \
VBoxSVC VBoxXPCOMIPCD
-OPTIONS_DEFINE= ALSA DBUS DEBUG DOCS GUESTADDITIONS NLS PULSEAUDIO \
- PYTHON QT5 R0LOGGING UDPTUNNEL VDE VNC WEBSERVICE VPX X11
+OPTIONS_DEFINE= ALSA DBUS DEBUG DOCS GUESTADDITIONS NLS PULSEAUDIO \
+ PYTHON QT5 R0LOGGING UDPTUNNEL VDE VNC WEBSERVICE VPX X11
OPTIONS_DEFAULT= DBUS QT5 UDPTUNNEL VNC WEBSERVICE X11
-OPTIONS_SUB= yes
+OPTIONS_SUB= yes
-DEBUG_DESC= Debug symbols, additional logs and assertions
+DEBUG_DESC= Debug symbols, additional logs and assertions
GUESTADDITIONS_DESC= Build with Guest Additions
-NLS_DESC= Native language support (requires QT5)
-QT5_DESC= Build with QT5 frontend (requires X11)
-R0LOGGING_DESC= Enable R0 logging (requires DEBUG)
-UDPTUNNEL_DESC= Build with UDP tunnel support
-VDE_DESC= Build with VDE support
-VNC_DESC= Build with VNC support
-VPX_DESC= Use libvpx for video recording
+NLS_DESC= Native language support (requires QT5)
+QT5_DESC= Build with QT5 frontend (requires X11)
+R0LOGGING_DESC= Enable R0 logging (requires DEBUG)
+UDPTUNNEL_DESC= Build with UDP tunnel support
+VDE_DESC= Build with VDE support
+VNC_DESC= Build with VNC support
+VPX_DESC= Use libvpx for video recording
WEBSERVICE_DESC= Build Webservice
ALSA_CONFIGURE_OFF= --disable-alsa
@@ -80,12 +80,25 @@ ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
DBUS_CONFIGURE_OFF= --disable-dbus
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
DEBUG_CONFIGURE_ON= --build-debug
+DOCS_USES= tex
+DOCS_USE= TEX=dvipsk:build,formats:build
DOCS_BUILD_DEPENDS= ${LOCALBASE}/share/xml/docbook/4.4/docbookx.dtd:textproc/docbook-xml
DOCS_CONFIGURE_OFF= --disable-docs
+DOCS_VARS= dbkxmldir=${LOCALBASE}/share/xml/docbook/4.4 \
+ dbkxsldir=${LOCALBASE}/share/xsl/docbook
NLS_IMPLIES= QT5
PULSEAUDIO_CONFIGURE_OFF= --disable-pulse
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+PYTHON_USES= python
+PYTHON_USES_OFF= python:build
+PYTHON_USE= PYTHON=distutils,noegginfo,noflavors
PYTHON_CONFIGURE_OFF= --disable-python
+PYTHON_VARS= pydistutils_pkgname=vboxapi pydistutils_pkgversion=1.0
+QT5_USES= gl qmake:no_env qt:5 xorg
+QT5_USE= QT=buildtools:build,core,dbus,gui,linguisttools:build,opengl \
+ QT=printsupport,widgets,x11extras XORG=xcb GL=gl
+QT5_CONFIGURE_ON= --enable-qt5
+QT5_CONFIGURE_OFF= --disable-qt
QT5_IMPLIES= X11
R0LOGGING_IMPLIES= DEBUG
UDPTUNNEL_CONFIGURE_OFF= --disable-udptunnel
@@ -95,6 +108,9 @@ VNC_CONFIGURE_ON= --enable-vnc
VNC_LIB_DEPENDS= libvncserver.so:net/libvncserver
VPX_CONFIGURE_OFF= --disable-libvpx
VPX_LIB_DEPENDS= libvpx.so:multimedia/libvpx
+WEBSERVICE_BUILD_DEPENDS= soapcpp2:devel/gsoap
+X11_USES= sdl xorg
+X11_USE= SDL=sdl XORG=x11,xcursor,xext,xinerama,xmu,xorgproto,xt
X11_CONFIGURE_OFF= --build-headless
ENV=
@@ -119,7 +135,7 @@ CONFLICTS_INSTALL+= virtualbox-ose
.endif
.if ${ARCH} == "amd64"
-_ELF32!= kldstat -q -m elf32 && echo yes || echo no
+_ELF32!= kldstat -q -m elf32 && ${ECHO_CMD} yes || ${ECHO_CMD} no
.endif
.if ${PORT_OPTIONS:MDEBUG}
@@ -138,49 +154,22 @@ LICENSE_PERMS_Additions= auto-accept
LICENSE_DISTFILES_Additions= ${GUESTADDITIONS}
.endif
-.if ${PORT_OPTIONS:MDOCS}
-DBKXMLDIR= ${LOCALBASE}/share/xml/docbook/4.4
-DBKXSLDIR= ${LOCALBASE}/share/xsl/docbook
-USES+= tex
-USE_TEX= dvipsk:build formats:build
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-USES+= python
-USE_PYTHON= distutils noegginfo noflavors
-PYDISTUTILS_PKGNAME= vboxapi
-PYDISTUTILS_PKGVERSION= 1.0
-.else
-USES+= python:build
-.endif
-
.if ${PORT_OPTIONS:MQT5}
-CONFIGURE_ARGS+= --enable-qt5
PLIST_SUB+= QT=""
-USES+= gl qmake:no_env qt:5 xorg
-USE_GL= gl glu
-USE_QT= buildtools:build core dbus gui linguisttools:build opengl
-USE_QT+= printsupport widgets x11extras
-USE_XORG= xcb
VBOX_PROGS+= VirtualBox
VBOX_UTILS+= VBoxTestOGL
VBOX_WITH_QT= 1
.else
-CONFIGURE_ARGS+= --disable-qt
PLIST_SUB+= QT="@comment "
.endif
.if ${PORT_OPTIONS:MWEBSERVICE}
-BUILD_DEPENDS+= soapcpp2:devel/gsoap
USE_RC_SUBR+= vboxwebsrv
VBOX_LINKS+= vboxwebsrv
VBOX_UTILS+= vboxwebsrv webtest
.endif
.if ${PORT_OPTIONS:MX11}
-USES+= sdl
-USE_SDL= sdl
-USE_XORG+= xorgproto x11 xcursor xext xinerama xmu xt
VBOX_PROGS+= VBoxSDL
.endif
@@ -207,10 +196,11 @@ KMK_FLAGS+= -j${MAKE_JOBS_NUMBER}
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == clang && ${OPSYS} == FreeBSD && \
- (${OSVERSION} < 1302505 || (${OSVERSION} >= 1400000 && ${OSVERSION} < 1400079))
-# llvm 13 and 14 included in FreeBSD fails to compile this legacy version of
+ (${OSVERSION} < 1302505 || (${OSVERSION} >= 1400000 && ${OSVERSION} < 1400079) || \
+ ${OSVERSION} >= 1400091)
+# llvm 13, 14 and 16 included in FreeBSD fails to compile this legacy version of
# virtualbox-ose, force llvm 15 on all versions of the FreeBSD except lastest 13
-# and 14 where the llvm 15 is included: PR#265539.
+# and several versions of 14 where the llvm 15 is included: PR#265539.
# Keep possibility to define different llvm via VBOX_LLVM_VER in make.conf.
BUILD_DEPENDS+= clang${VBOX_LLVM_VER}:devel/llvm${VBOX_LLVM_VER}
CC= clang${VBOX_LLVM_VER}