aboutsummaryrefslogtreecommitdiff
path: root/emulators/wine-devel
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/wine-devel')
-rw-r--r--emulators/wine-devel/Makefile6
-rw-r--r--emulators/wine-devel/distinfo6
-rw-r--r--emulators/wine-devel/files/patch-dlls_ntdll_unix_loader.c24
-rw-r--r--emulators/wine-devel/files/pkg32.sh5
-rw-r--r--emulators/wine-devel/pkg-plist8
5 files changed, 39 insertions, 10 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index bb1564e22a5a..992e40e91df8 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= wine
-DISTVERSION= 9.5
+DISTVERSION= 9.8
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= https://dl.winehq.org/wine/source/9.x/
@@ -27,7 +28,6 @@ CPE_VENDOR= winehq
CONFLICTS_INSTALL= wine
GNU_CONFIGURE= yes
-GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS+=--verbose \
--disable-kerberos \
--disable-tests \
@@ -154,7 +154,7 @@ PLIST_SUB+= WINE32="" WINE64="@comment " WINEARCH="i386"
.endif
pre-build:
- cd ${WRKSRC} && ${MAKE_CMD} depend
+ cd ${WRKSRC} && ${SETENVI} ${WRK_ENV} ${MAKE_CMD} depend
post-install:
.if ${ARCH} == i386
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index f35c9f5dfdad..371c35cdd3f8 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1712352368
-SHA256 (wine-9.5.tar.xz) = 12cf2fb7098134e2351c49ea3ba8f4da2a674f1f8722bebd4c3a4a6ca6d2e975
-SIZE (wine-9.5.tar.xz) = 30371420
+TIMESTAMP = 1715237210
+SHA256 (wine-9.8.tar.xz) = 86943c838eda8fad9a7940d4099703394bf1d1be9a1014342fed879c7dc3b993
+SIZE (wine-9.8.tar.xz) = 30297460
diff --git a/emulators/wine-devel/files/patch-dlls_ntdll_unix_loader.c b/emulators/wine-devel/files/patch-dlls_ntdll_unix_loader.c
new file mode 100644
index 000000000000..97f237d79c30
--- /dev/null
+++ b/emulators/wine-devel/files/patch-dlls_ntdll_unix_loader.c
@@ -0,0 +1,24 @@
+--- dlls/ntdll/unix/loader.c.orig 2024-04-05 17:03:05 UTC
++++ dlls/ntdll/unix/loader.c
+@@ -480,6 +480,21 @@ char *get_alternate_wineloader( WORD machine )
+
+ if (machine == current_machine) return NULL;
+
++ char* wineserver_path = getenv("WINESERVER");
++ if (wineserver_path != NULL && wineserver_path[0] == '/') {
++ char* s = remove_tail(wineserver_path, "server");
++ if (s != NULL) {
++ if (machine == IMAGE_FILE_MACHINE_AMD64) {
++ ret = malloc(strlen(s) + 3);
++ strcpy(ret, s);
++ strcat(ret, "64");
++ } else {
++ ret = s;
++ }
++ return ret;
++ }
++ }
++
+ /* try the 64-bit loader */
+ if (current_machine == IMAGE_FILE_MACHINE_I386 && machine == IMAGE_FILE_MACHINE_AMD64)
+ {
diff --git a/emulators/wine-devel/files/pkg32.sh b/emulators/wine-devel/files/pkg32.sh
index d75422997e12..64d82459c219 100644
--- a/emulators/wine-devel/files/pkg32.sh
+++ b/emulators/wine-devel/files/pkg32.sh
@@ -14,7 +14,6 @@ then
ln -s /usr/share/keys/pkg "$I386_ROOT/usr/share/keys/pkg"
fi
-ABI=$(pkg config ABI | sed s/amd64/i386/)
# Show what we're going to do, then do it.
-echo pkg -o ABI="$ABI" -o INSTALL_AS_USER=true -o RUN_SCRIPTS=false --rootdir "$I386_ROOT" "$@"
-exec pkg -o ABI="$ABI" -o INSTALL_AS_USER=true -o RUN_SCRIPTS=false --rootdir "$I386_ROOT" "$@"
+echo pkg -o ABI_FILE=/usr/lib32/libc.so.7 -o INSTALL_AS_USER=true -o RUN_SCRIPTS=false --rootdir "$I386_ROOT" "$@"
+exec pkg -o ABI_FILE=/usr/lib32/libc.so.7 -o INSTALL_AS_USER=true -o RUN_SCRIPTS=false --rootdir "$I386_ROOT" "$@"
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 933355a683be..44bc0b4daa7a 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -136,6 +136,7 @@ include/wine/windows/asynot.idl
include/wine/windows/asysta.idl
include/wine/windows/atlbase.h
include/wine/windows/atlcom.h
+include/wine/windows/atldef.h
include/wine/windows/atliface.h
include/wine/windows/atliface.idl
include/wine/windows/atlthunk.h
@@ -541,6 +542,8 @@ include/wine/windows/highlevelmonitorconfigurationapi.h
include/wine/windows/hlguids.h
include/wine/windows/hlink.h
include/wine/windows/hlink.idl
+include/wine/windows/holographicspaceinterop.h
+include/wine/windows/holographicspaceinterop.idl
include/wine/windows/hrtfapoapi.h
include/wine/windows/hrtfapoapi.idl
include/wine/windows/hstring.h
@@ -622,6 +625,7 @@ include/wine/windows/lmcons.h
include/wine/windows/lmerr.h
include/wine/windows/lmjoin.h
include/wine/windows/lmmsg.h
+include/wine/windows/lmremutl.h
include/wine/windows/lmserver.h
include/wine/windows/lmshare.h
include/wine/windows/lmstats.h
@@ -1637,6 +1641,7 @@ lib/wine/%%WINEARCH%%-unix/libd3d11.a
lib/wine/%%WINEARCH%%-unix/libd3d8.a
lib/wine/%%WINEARCH%%-unix/libd3d9.a
lib/wine/%%WINEARCH%%-unix/libd3dcompiler.a
+lib/wine/%%WINEARCH%%-unix/libd3dcompiler_39.a
lib/wine/%%WINEARCH%%-unix/libd3dcompiler_43.a
lib/wine/%%WINEARCH%%-unix/libd3dcompiler_46.a
lib/wine/%%WINEARCH%%-unix/libd3drm.a
@@ -1675,6 +1680,7 @@ lib/wine/%%WINEARCH%%-unix/libdxguid.a
lib/wine/%%WINEARCH%%-unix/libdxva2.a
lib/wine/%%WINEARCH%%-unix/libevr.a
lib/wine/%%WINEARCH%%-unix/libfaultrep.a
+lib/wine/%%WINEARCH%%-unix/libfltmgr.a
lib/wine/%%WINEARCH%%-unix/libgdi32.a
lib/wine/%%WINEARCH%%-unix/libgdiplus.a
lib/wine/%%WINEARCH%%-unix/libglu32.a
@@ -3118,6 +3124,7 @@ lib/wine/%%WINEARCH%%-windows/xmllite.dll
lib/wine/%%WINEARCH%%-windows/xolehlp.dll
lib/wine/%%WINEARCH%%-windows/xpsprint.dll
lib/wine/%%WINEARCH%%-windows/xpssvcs.dll
+share/applications/wine.desktop
%%WINE32%%share/man/de.UTF-8/man1/wine.1.gz
share/man/de.UTF-8/man1/winemaker.1.gz
share/man/de.UTF-8/man1/wineserver.1.gz
@@ -3147,7 +3154,6 @@ share/man/man1/wineserver.1.gz
share/man/man1/wmc.1.gz
share/man/man1/wrc.1.gz
%%WINE32%%share/man/pl.UTF-8/man1/wine.1.gz
-share/applications/wine.desktop
%%DATADIR%%/nls/c_037.nls
%%DATADIR%%/nls/c_10000.nls
%%DATADIR%%/nls/c_10001.nls