aboutsummaryrefslogtreecommitdiff
path: root/finance/aqbanking/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/aqbanking/Makefile')
-rw-r--r--finance/aqbanking/Makefile31
1 files changed, 24 insertions, 7 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
index 906c105db9b3..1f9e2f3a316c 100644
--- a/finance/aqbanking/Makefile
+++ b/finance/aqbanking/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= aqbanking
-PORTVERSION= 1.0.11
-PORTREVISION= 1
+PORTVERSION= 2.3.3
CATEGORIES= finance
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= aqbanking
@@ -15,23 +14,39 @@ MASTER_SITE_SUBDIR= aqbanking
MAINTAINER= ports@FreeBSD.org
COMMENT= Online banking interface and financial data framework
-LIB_DEPENDS= gwenhywfar.30:${PORTSDIR}/devel/gwenhywfar
+LIB_DEPENDS= gwenhywfar.48:${PORTSDIR}/devel/gwenhywfar
OPTIONS= OFX "LibOFX support" off \
KTOBLZCHECK "KtoBlzCheck support" off
-CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
USE_GCC= 3.4+
-INSTALLS_SHLIB= yes
+USE_QT_VER= 3
+QT_NONSTANDARD= special flags for threading
+
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ ${PTHREAD_CFLAGS}"
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ ${QTCPPFLAGS} ${PTHREAD_CFLAGS}"
+CONFIGURE_ENV+= LIBS="${QTCFGLIBS} ${PTHREAD_LIBS}"
+CONFIGURE_ENV+= QTDIR="${QT_PREFIX}"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS= --with-backends="aqhbci aqdtaus"
+CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
+ --with-qt-libraries=${QT_PREFIX}/lib \
+ --with-extra-libs=${LOCALBASE}/lib \
+ --with-extra-includes=${LOCALBASE}/include
.include <bsd.port.pre.mk>
.if defined(WITH_OFX)
LIB_DEPENDS+= ofx.3:${PORTSDIR}/finance/libofx
+CONFIGURE_ARGS= --with-backends="aqhbci aqdtaus aqofxconnect"
CONFIGURE_ARGS+=--enable-libofx
PLIST_SUB+= OFX=""
.else
@@ -39,9 +54,11 @@ CONFIGURE_ARGS+=--disable-libofx
PLIST_SUB+= OFX="@comment "
.endif
+CONFIGURE_ARGS+= --with-frontends="cbanking qbanking"
+
# no configure option to disable ktoblzcheck support (yet)
.if defined(WITH_KTOBLZCHECK) || exists(${LOCALBASE}/lib/libktoblzcheck.so.4)
-LIB_DEPENDS+= ktoblzcheck.4:${PORTSDIR}/finance/ktoblzcheck
+LIB_DEPENDS+= ktoblzcheck.6:${PORTSDIR}/finance/ktoblzcheck
.endif
post-patch: