aboutsummaryrefslogtreecommitdiff
path: root/finance/beanie
diff options
context:
space:
mode:
Diffstat (limited to 'finance/beanie')
-rw-r--r--finance/beanie/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/finance/beanie/Makefile b/finance/beanie/Makefile
index afff393a1db6..126e20d3ec7e 100644
--- a/finance/beanie/Makefile
+++ b/finance/beanie/Makefile
@@ -22,5 +22,8 @@ MAKE_JOBS_UNSAFE= yes
post-patch:
@${CP} ${WRKSRC}/beanie.mk.sample ${WRKSRC}/beanie.mk
@${CP} ${WRKSRC}/tmac/lhead.sample.r ${WRKSRC}/tmac/lhead.r
+# Fix the build with -fno-common (for Clang 11 and GCC 10)
+ @${REINPLACE_CMD} -e 's,int[[:blank:]]*itemno,extern &,' \
+ ${WRKSRC}/import/salesorder.c
.include <bsd.port.mk>