aboutsummaryrefslogtreecommitdiff
path: root/finance/cbb/files/patch-reports_Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'finance/cbb/files/patch-reports_Makefile.in')
-rw-r--r--finance/cbb/files/patch-reports_Makefile.in37
1 files changed, 37 insertions, 0 deletions
diff --git a/finance/cbb/files/patch-reports_Makefile.in b/finance/cbb/files/patch-reports_Makefile.in
new file mode 100644
index 000000000000..812a1e772978
--- /dev/null
+++ b/finance/cbb/files/patch-reports_Makefile.in
@@ -0,0 +1,37 @@
+--- reports/Makefile.in.orig 2014-02-17 17:08:01.000000000 +0100
++++ reports/Makefile.in 2014-02-17 17:08:39.000000000 +0100
+@@ -32,7 +32,7 @@
+ includedir = @includedir@
+ oldincludedir = /usr/include
+
+-DISTDIR =
++DISTDIR = ${STAGEDIR}
+
+ pkgdatadir = $(datadir)/@PACKAGE@
+ pkglibdir = $(libdir)/@PACKAGE@
+@@ -188,19 +188,19 @@
+ # Create install directories
+ make-dirs:
+ umask 022; \
+- if test '!' -d $(CBB_BINDIR); then \
+- mkdir -p $(CBB_BINDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_BINDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_BINDIR); \
+ fi; \
+- if test '!' -d $(CBB_LIBDIR); then \
+- mkdir -p $(CBB_LIBDIR); \
++ if test '!' -d $(DISTDIR)$(CBB_LIBDIR); then \
++ mkdir -p $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ install-exec-local: make-dirs
+ if test -n "$(CBB_BINFILES)"; then \
+- $(INSTALL) $(CBB_BINFILES) $(CBB_BINDIR); \
++ $(INSTALL) $(CBB_BINFILES) $(DISTDIR)$(CBB_BINDIR); \
+ fi;
+ if test -n "$(CBB_LIBFILES)"; then \
+- $(INSTALL) $(CBB_LIBFILES) $(CBB_LIBDIR); \
++ $(INSTALL) $(CBB_LIBFILES) $(DISTDIR)$(CBB_LIBDIR); \
+ fi;
+
+ dist-hook: