aboutsummaryrefslogtreecommitdiff
path: root/finance/grisbi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'finance/grisbi/Makefile')
-rw-r--r--finance/grisbi/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/finance/grisbi/Makefile b/finance/grisbi/Makefile
index 53ae46656433..ae112b15f602 100644
--- a/finance/grisbi/Makefile
+++ b/finance/grisbi/Makefile
@@ -1,8 +1,7 @@
PORTNAME= grisbi
-PORTVERSION= 2.0.5
-PORTREVISION= 3
+PORTVERSION= 3.0.0
CATEGORIES= finance
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION:R}.x/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION:R}.x/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Personal accounting application
@@ -10,21 +9,20 @@ WWW= https://www.grisbi.org/
LICENSE= GPLv2
+BUILD_DEPENDS= p5-XML-Parser>0:textproc/p5-XML-Parser
LIB_DEPENDS= libofx.so:finance/libofx \
libharfbuzz.so:print/harfbuzz \
libfreetype.so:print/freetype2 \
libgoffice-0.10.so:devel/goffice \
libfontconfig.so:x11-fonts/fontconfig
-USES= tar:bzip2 desktop-file-utils gmake gnome iconv localbase \
- pkgconfig shared-mime-info ssl
+USES= desktop-file-utils gmake gnome iconv localbase \
+ pkgconfig shared-mime-info ssl tar:bzip2
USE_GNOME= cairo gdkpixbuf2 glib20 gtk30 intltool libgsf libxml2
GNU_CONFIGURE= yes
CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
-GLIB_SCHEMAS= org.gtk.grisbi.gschema.xml
-
OPTIONS_DEFINE= DOCS NLS
.include <bsd.port.options.mk>