aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
Diffstat (limited to 'finance')
-rw-r--r--finance/aqbanking/Makefile2
-rw-r--r--finance/emma/Makefile2
-rw-r--r--finance/gnofin/Makefile2
-rw-r--r--finance/khacc/Makefile3
-rw-r--r--finance/kmymoney-kde4/Makefile2
-rw-r--r--finance/kmymoney2/Makefile2
-rw-r--r--finance/ktoblzcheck/Makefile2
-rw-r--r--finance/libofx/Makefile2
-rw-r--r--finance/openhbci/Makefile2
-rw-r--r--finance/qhacc/Makefile2
10 files changed, 10 insertions, 11 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
index 8aa648e39932..728b9cf17057 100644
--- a/finance/aqbanking/Makefile
+++ b/finance/aqbanking/Makefile
@@ -21,7 +21,7 @@ OPTIONS= OFX "LibOFX support" off \
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GETTEXT= yes
diff --git a/finance/emma/Makefile b/finance/emma/Makefile
index 8db32172489a..5b48d8099f99 100644
--- a/finance/emma/Makefile
+++ b/finance/emma/Makefile
@@ -20,7 +20,7 @@ USE_X_PREFIX= yes
USE_PYTHON= yes
USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/finance/gnofin/Makefile b/finance/gnofin/Makefile
index a29ab9b49115..2e95a742630d 100644
--- a/finance/gnofin/Makefile
+++ b/finance/gnofin/Makefile
@@ -18,7 +18,7 @@ COMMENT= Light-weight GNOME based financial management program
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/finance/khacc/Makefile b/finance/khacc/Makefile
index 63eb1d1d9189..5afbdaa47f23 100644
--- a/finance/khacc/Makefile
+++ b/finance/khacc/Makefile
@@ -20,8 +20,7 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_KDELIBS_VER= 3
USE_PERL5_BUILD= yes
USE_GMAKE= yes
-WANT_AUTOMAKE_VER= 19
-WANT_AUTOCONF_VER= 259
+USE_AUTOTOOLS= automake:19:env autoconf:259:env
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qhacc-config=${X11BASE}/bin
diff --git a/finance/kmymoney-kde4/Makefile b/finance/kmymoney-kde4/Makefile
index 54493fe77516..a81bd074121d 100644
--- a/finance/kmymoney-kde4/Makefile
+++ b/finance/kmymoney-kde4/Makefile
@@ -20,7 +20,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_PERL5= yes
USE_BZIP2= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
MAN1= kmymoney2.1
diff --git a/finance/kmymoney2/Makefile b/finance/kmymoney2/Makefile
index 54493fe77516..a81bd074121d 100644
--- a/finance/kmymoney2/Makefile
+++ b/finance/kmymoney2/Makefile
@@ -20,7 +20,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_PERL5= yes
USE_BZIP2= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
MAN1= kmymoney2.1
diff --git a/finance/ktoblzcheck/Makefile b/finance/ktoblzcheck/Makefile
index 5f62c1f2b13b..9a4673a82923 100644
--- a/finance/ktoblzcheck/Makefile
+++ b/finance/ktoblzcheck/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Check bank codes of German banks
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index 54824f827c22..23041008a7c3 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
USE_GMAKE= yes
USE_GNOME= gnometarget
USE_GETOPT_LONG= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
--with-opensp-includes=${LOCALBASE}/include/OpenSP
diff --git a/finance/openhbci/Makefile b/finance/openhbci/Makefile
index 61a6b73926ea..3d039a5b4c28 100644
--- a/finance/openhbci/Makefile
+++ b/finance/openhbci/Makefile
@@ -18,7 +18,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-0.9.17
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
-USE_INC_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15:inc
.include <bsd.port.pre.mk>
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index c6296add101c..c40ae044d97c 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -21,7 +21,7 @@ USE_QT_VER= 3
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qt-moc=${QT_PREFIX}/bin \
--with-qt-libs=${QT_PREFIX}/lib