aboutsummaryrefslogtreecommitdiff
path: root/french/tvdownloader/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'french/tvdownloader/Makefile')
-rw-r--r--french/tvdownloader/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/french/tvdownloader/Makefile b/french/tvdownloader/Makefile
index 5e0e207513f8..3d407ce9e8a3 100644
--- a/french/tvdownloader/Makefile
+++ b/french/tvdownloader/Makefile
@@ -11,26 +11,22 @@ MASTER_SITE_SUBDIR=
MAINTAINER= thierry@FreeBSD.org
COMMENT= Download podcasts and videos from French websites
+LICENSE= GPLv2
+
RUN_DEPENDS= msdl:${PORTSDIR}/multimedia/msdl \
rtmpdump:${PORTSDIR}/multimedia/rtmpdump \
${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto\
- ${PYTHON_SITELIBDIR}/${MECHA_EGG}:${PORTSDIR}/www/py-mechanize
+ ${PYTHON_SITELIBDIR}/mechanize/_mechanize.py:${PORTSDIR}/www/py-mechanize
MECHA_VER= 0.2.5
MECHA_EGG= mechanize-${MECHA_VER}-${PYTHON_VERSION:S/thon//}${PYEASYINSTALL_OSARCH}.egg
USE_PYTHON= yes
+USES= shebangfix
+SHEBANG_FILES= Makefile src/Makefile doc/installdox
ALL_TARGET= build
-LICENSE= GPLv2
-
-NO_STAGE= yes
-post-patch:
- ${REINPLACE_CMD} -e 's|@python|@${PYTHON_CMD}|' \
- ${WRKSRC}/Makefile \
- ${WRKSRC}/src/Makefile
-
pre-configure:
${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
${WRKSRC}/tvdownloader.sh