aboutsummaryrefslogtreecommitdiff
path: root/ftp/kasablanca
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/kasablanca')
-rw-r--r--ftp/kasablanca/Makefile29
-rw-r--r--ftp/kasablanca/distinfo2
-rw-r--r--ftp/kasablanca/files/patch-ftplib.cpp28
-rw-r--r--ftp/kasablanca/files/patch-ftplib.h13
-rw-r--r--ftp/kasablanca/files/patch-ftpthread.cpp19
-rw-r--r--ftp/kasablanca/files/patch-kbfileinfo.h15
-rw-r--r--ftp/kasablanca/files/patch-kbitem.h15
-rw-r--r--ftp/kasablanca/pkg-descr9
-rw-r--r--ftp/kasablanca/pkg-plist38
9 files changed, 0 insertions, 168 deletions
diff --git a/ftp/kasablanca/Makefile b/ftp/kasablanca/Makefile
deleted file mode 100644
index ae220bb0e5a1..000000000000
--- a/ftp/kasablanca/Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
-# Create by: Markus Brueffer <markus@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= kasablanca
-PORTVERSION= 0.4.0.2
-PORTREVISION= 8
-CATEGORIES= ftp kde
-MASTER_SITES= BERLIOS \
- http://www.hitnet.rwth-aachen.de/~brueffer/distfiles/
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Graphical ftp client for KDE
-
-DEPRECATED= Depends on QT3; unmaintained
-EXPIRATION_DATE= 2013-07-01
-
-EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
-
-USE_KDELIBS_VER=3
-USE_GMAKE= yes
-USE_OPENSSL= yes
-USE_AUTOTOOLS= libtool
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e 's|\(-lssl\)|\1 -lcrypto|' \
- ${WRKSRC}/src/Makefile.in
-
-.include <bsd.port.mk>
diff --git a/ftp/kasablanca/distinfo b/ftp/kasablanca/distinfo
deleted file mode 100644
index cb3b1a460d1a..000000000000
--- a/ftp/kasablanca/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (kasablanca-0.4.0.2.tar.gz) = 2864d4260f692f61845897ea3379f397b55e6751dfea0402a4968cfa1e4dec08
-SIZE (kasablanca-0.4.0.2.tar.gz) = 699799
diff --git a/ftp/kasablanca/files/patch-ftplib.cpp b/ftp/kasablanca/files/patch-ftplib.cpp
deleted file mode 100644
index 1e784f49276b..000000000000
--- a/ftp/kasablanca/files/patch-ftplib.cpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/ftplib.cpp.orig Wed Feb 2 23:31:16 2005
-+++ src/ftplib.cpp Wed Feb 2 23:37:05 2005
-@@ -71,6 +71,14 @@
- #define FTPLIB_READ 1
- #define FTPLIB_WRITE 2
-
-+#ifndef __USE_LARGEFILE64
-+ #define FOPEN fopen
-+ #define FSEEKO fseeko
-+#else
-+ #define FOPEN fopen64
-+ #define FSEEKO fseeko64
-+#endif
-+
- /*
- * Constructor
- */
-@@ -1138,8 +1146,8 @@
- if (typ == FTPLIB_FILE_WRITE) { ac[0] = 'r'; ac[1] = '\0'; }
- if (mode == ftplib::image) ac[1] = 'b';
-
-- local = fopen64(localfile, ac);
-- if (typ == FTPLIB_FILE_WRITE_APPEND) fseeko64(local,mp_netbuf->offset,SEEK_SET);
-+ local = FOPEN(localfile, ac);
-+ if (typ == FTPLIB_FILE_WRITE_APPEND) FSEEKO(local,mp_netbuf->offset,SEEK_SET);
-
- if (local == NULL)
- {
diff --git a/ftp/kasablanca/files/patch-ftplib.h b/ftp/kasablanca/files/patch-ftplib.h
deleted file mode 100644
index bbb2fe61e5b9..000000000000
--- a/ftp/kasablanca/files/patch-ftplib.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/ftplib.h.orig Wed Feb 2 23:29:55 2005
-+++ src/ftplib.h Wed Feb 2 23:30:51 2005
-@@ -56,6 +56,10 @@
- #include <sys/time.h>
- #include <openssl/ssl.h>
-
-+#ifdef __FreeBSD__
-+#define off64_t off_t
-+#endif
-+
- using namespace std;
-
- /**
diff --git a/ftp/kasablanca/files/patch-ftpthread.cpp b/ftp/kasablanca/files/patch-ftpthread.cpp
deleted file mode 100644
index 3d9802b46d12..000000000000
--- a/ftp/kasablanca/files/patch-ftpthread.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/ftpthread.cpp.orig Mon Jan 31 14:24:47 2005
-+++ src/ftpthread.cpp Thu Feb 3 00:45:36 2005
-@@ -31,6 +31,7 @@
-
- #include <iostream>
- #include <list>
-+#include <stdlib.h>
-
- #include "kbconfig.h"
- #include "ftplib.h"
-@@ -1226,7 +1227,7 @@
- loc--;
- }
-
-- off64_t size = atoll(buffer.substr( sizebegin, datebegin - sizebegin).c_str());
-+ off64_t size = strtoll(buffer.substr( sizebegin, datebegin - sizebegin).c_str(), (char **)NULL, 10);
-
- filestring.erase();
- filestring.append(buffer, fileloc, buffer.length() - fileloc);
diff --git a/ftp/kasablanca/files/patch-kbfileinfo.h b/ftp/kasablanca/files/patch-kbfileinfo.h
deleted file mode 100644
index ad7a98a3b799..000000000000
--- a/ftp/kasablanca/files/patch-kbfileinfo.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/kbfileinfo.h.orig Fri Jan 28 00:56:07 2005
-+++ src/kbfileinfo.h Wed Feb 2 23:17:14 2005
-@@ -12,7 +12,12 @@
- #ifndef KBFILEINFO_H
- #define KBFILEINFO_H
-
-+#include <fcntl.h>
- #include <qfileinfo.h>
-+
-+#ifdef __FreeBSD__
-+#define off64_t off_t
-+#endif
-
- class KbItem;
-
diff --git a/ftp/kasablanca/files/patch-kbitem.h b/ftp/kasablanca/files/patch-kbitem.h
deleted file mode 100644
index 1bfb40748ee7..000000000000
--- a/ftp/kasablanca/files/patch-kbitem.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/kbitem.h.orig Fri Jan 28 00:56:07 2005
-+++ src/kbitem.h Wed Feb 2 23:38:36 2005
-@@ -12,7 +12,12 @@
- #ifndef KBITEM_H
- #define KBITEM_H
-
-+#include <fcntl.h>
- #include <qlistview.h>
-+
-+#ifdef __FreeBSD__
-+#define off64_t off_t
-+#endif
-
- class KbFileInfo;
-
diff --git a/ftp/kasablanca/pkg-descr b/ftp/kasablanca/pkg-descr
deleted file mode 100644
index abf668ff8073..000000000000
--- a/ftp/kasablanca/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-Kasablanca is a graphical ftp client for KDE.
-
-Features:
- o ftps encryption via AUTH TLS
- o fxp (direct server to server transfer)
- o bookmarking system
- o concurrent connections to multiple hosts
-
-WWW: http://kasablanca.berlios.de/
diff --git a/ftp/kasablanca/pkg-plist b/ftp/kasablanca/pkg-plist
deleted file mode 100644
index ef283cb4cf28..000000000000
--- a/ftp/kasablanca/pkg-plist
+++ /dev/null
@@ -1,38 +0,0 @@
-bin/kasablanca
-share/applnk/Utilities/kasablanca.desktop
-share/apps/kasablanca/about.png
-share/apps/kasablanca/kasablancaui.rc
-share/config.kcfg/kbconfig.kcfg
-share/doc/HTML/en/kasablanca/common
-share/doc/HTML/en/kasablanca/index.cache.bz2
-share/doc/HTML/en/kasablanca/index.docbook
-share/icons/hicolor/128x128/apps/kasablanca.png
-share/icons/hicolor/16x16/apps/kasablanca.png
-share/icons/hicolor/22x22/apps/kasablanca.png
-share/icons/hicolor/32x32/apps/kasablanca.png
-share/icons/hicolor/48x48/apps/kasablanca.png
-share/icons/hicolor/64x64/apps/kasablanca.png
-share/locale/de/LC_MESSAGES/kasablanca.mo
-share/locale/pl/LC_MESSAGES/kasablanca.mo
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/64x64
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32
-@dirrmtry share/icons/hicolor/22x22/apps
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/128x128/apps
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-@dirrm share/doc/HTML/en/kasablanca
-@dirrmtry share/doc/HTML/en
-@dirrmtry share/doc/HTML
-@dirrmtry share/config.kcfg
-@dirrm share/apps/kasablanca
-@dirrmtry share/apps
-@dirrmtry share/applnk/Utilities
-@dirrmtry share/applnk