aboutsummaryrefslogtreecommitdiff
path: root/ftp/php-fastdfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/php-fastdfs/Makefile')
-rw-r--r--ftp/php-fastdfs/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/ftp/php-fastdfs/Makefile b/ftp/php-fastdfs/Makefile
new file mode 100644
index 000000000000..82e6c1d7ed92
--- /dev/null
+++ b/ftp/php-fastdfs/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= fastdfs
+DISTVERSION= 5.0.11
+CATEGORIES= ftp
+PKGNAMEPREFIX= ${PHP_PKGNAMEPREFIX}
+
+MAINTAINER= daniel@blodan.se
+COMMENT?= PHP module for accessing a FastDFS cluster
+
+LICENSE= GPLv3+
+
+LIB_DEPENDS= libfastcommon.so:devel/libfastcommon \
+ libfdfsclient.so:ftp/fastdfs
+
+USE_GITHUB= yes
+GH_ACCOUNT= happyfish100
+GH_PROJECT= fastdfs
+GH_TAGNAME= 1e50b4f
+
+USES= php:ext
+
+WRKSRC_SUBDIR= php_client
+CONFIGURE_ENV= ROOT=${LOCALBASE}
+
+PHP_MODNAME= fastdfs_client
+
+.include <bsd.port.mk>