aboutsummaryrefslogtreecommitdiff
path: root/games/DDNet/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'games/DDNet/files/patch-CMakeLists.txt')
-rw-r--r--games/DDNet/files/patch-CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/games/DDNet/files/patch-CMakeLists.txt b/games/DDNet/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..d87f98845d88
--- /dev/null
+++ b/games/DDNet/files/patch-CMakeLists.txt
@@ -0,0 +1,24 @@
+--- CMakeLists.txt.orig 2022-02-12 22:26:38 UTC
++++ CMakeLists.txt
+@@ -2566,11 +2566,17 @@ if(NOT DEV)
+ install(TARGETS ${TARGET_ANTIBOT} DESTINATION ${CMAKE_INSTALL_LIBDIR}/ddnet COMPONENT server)
+ endif()
+ install(TARGETS ${TARGETS_TOOLS} DESTINATION ${CMAKE_INSTALL_LIBDIR}/ddnet COMPONENT tools)
+- install(FILES other/ddnet.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications COMPONENT client)
+- install(FILES other/ddnet.appdata.xml DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/metainfo COMPONENT client)
++ if(CLIENT)
++ install(FILES other/ddnet.desktop DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/applications COMPONENT client)
++ install(FILES other/ddnet.appdata.xml DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/metainfo COMPONENT client)
++ endif()
+ foreach(SIZE 16 32 48 256)
+- install(FILES other/icons/DDNet_${SIZE}x${SIZE}x32.png DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${SIZE}x${SIZE}/apps RENAME ddnet.png COMPONENT client)
+- install(FILES other/icons/DDNet-Server_${SIZE}x${SIZE}x32.png DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${SIZE}x${SIZE}/apps RENAME ddnet-server.png COMPONENT server)
++ if(CLIENT)
++ install(FILES other/icons/DDNet_${SIZE}x${SIZE}x32.png DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${SIZE}x${SIZE}/apps RENAME ddnet.png COMPONENT client)
++ endif()
++ if(SERVER)
++ install(FILES other/icons/DDNet-Server_${SIZE}x${SIZE}x32.png DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/${SIZE}x${SIZE}/apps RENAME ddnet-server.png COMPONENT server)
++ endif()
+ endforeach()
+ endif()
+