aboutsummaryrefslogtreecommitdiff
path: root/games/asteroid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/asteroid/Makefile')
-rw-r--r--games/asteroid/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/games/asteroid/Makefile b/games/asteroid/Makefile
index c5112b495799..cccd6ab558d7 100644
--- a/games/asteroid/Makefile
+++ b/games/asteroid/Makefile
@@ -2,15 +2,20 @@
# $FreeBSD$
PORTNAME= asteroid
-PORTVERSION= 1.2
+PORTVERSION= 1.2.1
CATEGORIES= games
-MASTER_SITES= SF/chaoslizard/Asteroid/v1.2%20%282012%20Apr.%2022%29/
MAINTAINER= nemysis@gmx.ch
COMMENT= Modern version of the arcade classic Asteroid
LICENSE= GPLv3
+USE_GITHUB= yes
+GH_ACCOUNT= chazomaticus
+GH_PROJECT= asteroid
+GH_TAGNAME= master
+GH_COMMIT= 6d23595
+
USE_GL= glut
USE_SDL= mixer sdl
USE_GNOME= gtk20
@@ -19,8 +24,7 @@ INSTALLS_ICONS= yes
USE_CMAKE= yes
CMAKE_VERBOSE= yes
-PORTDATA= *
-PORTDOCS= AUTHORS NEWS README
+PORTDOCS= AUTHORS NEWS README.md
.include <bsd.port.options.mk>
@@ -29,5 +33,6 @@ post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
+ @-update-desktop-database -q
.include <bsd.port.mk>