aboutsummaryrefslogtreecommitdiff
path: root/games/bubble-chains/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/bubble-chains/Makefile')
-rw-r--r--games/bubble-chains/Makefile64
1 files changed, 29 insertions, 35 deletions
diff --git a/games/bubble-chains/Makefile b/games/bubble-chains/Makefile
index 60019cebf3c2..85cd2c408027 100644
--- a/games/bubble-chains/Makefile
+++ b/games/bubble-chains/Makefile
@@ -3,34 +3,27 @@
PORTNAME= bubble-chains
PORTVERSION= 0.1.1
-DISTVERSIONSUFFIX= -src
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games
-MASTER_SITES= http://bubble-chains.sintegrial.com/files/ \
- SF/nemysisfreebsdp/${CATEGORIES}/:icons
-DISTFILES= chains-${DISTVERSIONFULL}${EXTRACT_SUFX} \
- ${PORTNAME}.png:icons
-EXTRACT_ONLY= ${DISTFILES:N*\:icons:C/:.*//}
MAINTAINER= ports@FreeBSD.org
-COMMENT= The aim is to remove all of the targets on each level
+COMMENT= 2D arcade-puzzle game based on Qt/SDL
LICENSE= GPLv2
-BROKEN= unfetchable
-DEPRECATED= does not fetch
-EXPIRATION_DATE=2016-04-23
+BUILD_DEPENDS= icotool:graphics/icoutils
-WRKSRC= ${WRKDIR}/chains-${DISTVERSION}-src
+USE_GITHUB= yes
+GH_ACCOUNT= SanskritFritz
-USES= 7z dos2unix qmake
-DOS2UNIX_GLOB= *.pro *.cpp *.h *.ui *.ui *.rc *.htm *.dat *.css
-USE_SDL= sdl image mixer
-USE_GL= glut glew glu
+USES= dos2unix qmake
+DOS2UNIX_GLOB= *.pro *.cpp *.h *.ui *.rc *.htm *.dat *.css
+USE_SDL= mixer sdl
+USE_GL= gl
USE_XORG= xrandr
USE_QT4= moc_build rcc_build uic_build iconengines_run imageformats_run \
corelib svg xml opengl network
-LDFLAGS+= -L${LOCALBASE}/lib -lX11 -lSDL
+QMAKE_SOURCE_PATH= ${WRKSRC}/Game.pro
PORTDOCS= README
OPTIONS_DEFINE= DOCS
@@ -39,24 +32,25 @@ DESKTOP_ENTRIES="Bubble Chains" "" "${PORTNAME}" \
"${PORTNAME}" "Game;ArcadeGame;" ""
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/games/chains|${DATADIR}|' \
- ${WRKSRC}/main.cpp ${WRKSRC}/Game.pro
-
-post-configure:
- @${REINPLACE_CMD} -e 's|CFLAGS =|CFLAGS ?=|; \
- s|CXXFLAGS =|CXXFLAGS ?=|' \
- ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/chains \
- ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} data ${STAGEDIR}${DATADIR})
-
- ${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \
- ${STAGEDIR}${PREFIX}/share/pixmaps/
- ${INSTALL_DATA} ${WRKSRC}/icon.ico \
- ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.ico
-
+ @${REINPLACE_CMD} -e 's|bin/chains|bin/bubble-chains|; \
+ s|/usr/bin|${PREFIX}/bin|; \
+ s|/usr/share/chains|${DATADIR}|' \
+ ${WRKSRC}/Game.pro
+ @${REINPLACE_CMD} -e 's|/usr/share/chains|${DATADIR}|' \
+ ${WRKSRC}/main.cpp
+
+post-build:
+.for i in 16 32 48
+ @${MKDIR} ${WRKDIR}/icons/hicolor/${i}x${i}/apps
+ ${LOCALBASE}/bin/icotool -x -b 32 -w ${i} \
+ -o ${WRKDIR}/icons/hicolor/${i}x${i}/apps/bubble-chains.png \
+ ${WRKSRC}/icon.ico
+.endfor
+
+post-install:
+ cd ${WRKDIR} && ${COPYTREE_SHARE} icons ${STAGEDIR}${PREFIX}/share
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}