aboutsummaryrefslogtreecommitdiff
path: root/games/doomsday/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/doomsday/Makefile')
-rw-r--r--games/doomsday/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/games/doomsday/Makefile b/games/doomsday/Makefile
index b06f38636990..119ccfeaba64 100644
--- a/games/doomsday/Makefile
+++ b/games/doomsday/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= doomsday
-PORTVERSION= 2.1.0
-PORTREVISION= 1
+PORTVERSION= 2.1.1
CATEGORIES= games
MASTER_SITES= SF/deng/Doomsday%20Engine/${PORTVERSION}
@@ -17,13 +16,14 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libfluidsynth.so:audio/fluidsynth
RUN_DEPENDS= timidity:audio/timidity
-USES= cmake compiler:c++11-lib gl localbase:ldflags ninja openal pkgconfig python:2.7,build qt:5
+USES= cmake compiler:c++11-lib gl localbase:ldflags ninja openal pkgconfig \
+ python:2.7,build qt:5 sdl
USE_GL= gl glu
USE_LDCONFIG= yes
USE_SDL= sdl2 mixer2
USE_XORG= x11 sm ice xext xrandr xxf86vm
-USE_QT= buildtools_build core gui network widgets qmake opengl x11extras
+USE_QT= buildtools_build core gui network widgets qmake_build opengl x11extras
CMAKE_ARGS+= -DDENG_ENABLE_COTIRE=OFF -DDENG_ASSIMP_EMBEDDED=OFF
LDFLAGS+= -lexecinfo