aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear
diff options
context:
space:
mode:
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile12
-rw-r--r--games/flightgear/distinfo4
-rw-r--r--games/flightgear/files/patch-CMakeLists.txt23
-rw-r--r--games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx12
-rw-r--r--games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx12
-rw-r--r--games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx11
-rw-r--r--games/flightgear/files/patch-src-Airports-runwayprefs.cxx11
-rw-r--r--games/flightgear/files/patch-src-Autopilot-inputvalue.cxx12
-rw-r--r--games/flightgear/files/patch-src-Canvas-ShivaVG-src-shDefs.h11
-rw-r--r--games/flightgear/files/patch-src-FDM-YASim-YASim.cxx12
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx12
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx12
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx11
-rw-r--r--games/flightgear/files/patch-src-Instrumentation-dclgps.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-ATC-Inputs.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-ATC-Outputs.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-AV400.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-AV400Sim.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-atlas.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-garmin.cxx11
-rw-r--r--games/flightgear/files/patch-src-Network-nmea.cxx11
-rw-r--r--games/flightgear/files/patch-src-Systems-electrical.cxx11
-rw-r--r--games/flightgear/files/patch-src-Systems-system_mgr.cxx11
-rw-r--r--games/flightgear/pkg-plist1
24 files changed, 22 insertions, 244 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index bb36aa4d54f5..e71c534c6364 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= flightgear
-PORTVERSION= 2.6.0
-PORTREVISION= 3
+PORTVERSION= 2.8.0
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/ \
@@ -38,19 +37,12 @@ USE_OPENAL= al alut
USE_CMAKE= yes
CMAKE_ARGS+= -DJPEG_FACTORY:BOOL=ON \
-DFG_DATA_DIR:PATH=${LOCALBASE}/share/${PORTNAME} \
- -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man \
- -DCMAKE_INSTALL_DOCDIR:PATH=${DOCSDIR}
-
-PORTDOCS= README README.OSG README.OpenAL README.SimGear README.plib
+ -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man
MAN1= js_demo.1 fgjs.1 gl-info.1 fgfs.1 fgpanel.1 terrasync.1
.include <bsd.port.options.mk>
-.if empty(PORT_OPTIONS:MDOCS)
-CMAKE_ARGS+= -DNOPORTDOCS:BOOL=ON
-.endif
-
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/js_server/js_server ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
diff --git a/games/flightgear/distinfo b/games/flightgear/distinfo
index 7ed5b8470acd..8ec8b59e4d34 100644
--- a/games/flightgear/distinfo
+++ b/games/flightgear/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flightgear-2.6.0.tar.bz2) = 1554efbe20ad5002ad169225605ae95fca46d381bdff03dd624d92cf24b1a40f
-SIZE (flightgear-2.6.0.tar.bz2) = 2280644
+SHA256 (flightgear-2.8.0.tar.bz2) = bfda4f269d90128f4e4cb828de692a49dc0b93db41fe20a2b5272f3f271f3a01
+SIZE (flightgear-2.8.0.tar.bz2) = 2311023
diff --git a/games/flightgear/files/patch-CMakeLists.txt b/games/flightgear/files/patch-CMakeLists.txt
index 1abbcffbfb62..4d92c0ec8292 100644
--- a/games/flightgear/files/patch-CMakeLists.txt
+++ b/games/flightgear/files/patch-CMakeLists.txt
@@ -1,22 +1,11 @@
---- CMakeLists.txt.orig 2012-02-17 23:41:13.982306000 +0100
-+++ CMakeLists.txt 2012-03-09 15:39:46.949702574 +0100
-@@ -226,7 +226,7 @@
- endif(LIBSVN_FOUND)
+--- CMakeLists.txt.orig 2012-08-27 18:14:13.000000000 +0200
++++ CMakeLists.txt 2012-08-27 18:14:52.000000000 +0200
+@@ -225,7 +225,7 @@
+ endif(LIBSVN_FOUND)
endif(ENABLE_LIBSVN)
-find_package(PLIB REQUIRED puaux pu js fnt)
+find_package(PLIB REQUIRED puaux pu js fnt net)
- find_package(SimGear 2.6.0 REQUIRED)
- if (JPEG_FACTORY)
-@@ -342,7 +342,9 @@
- README.OSG
- README.SimGear)
-
--INSTALL(FILES ${INSTALL_DOCS} DESTINATION ${CMAKE_INSTALL_DOCDIR} OPTIONAL)
-+if(NOT NOPORTDOCS)
-+ INSTALL(FILES ${INSTALL_DOCS} DESTINATION ${CMAKE_INSTALL_DOCDIR} OPTIONAL)
-+endif()
-
- #-----------------------------------------------------------------------------
- ### uninstall target
+ # FlightGear and SimGear versions need to match
+ find_package(SimGear ${FLIGHTGEAR_VERSION} REQUIRED)
diff --git a/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx b/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx
deleted file mode 100644
index d2827ffb333d..000000000000
--- a/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreate.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/AIModel/AIFlightPlanCreate.cxx.orig 2012-04-28 20:11:14.268235838 +0300
-+++ src/AIModel/AIFlightPlanCreate.cxx 2012-04-28 20:11:29.798235529 +0300
-@@ -18,6 +18,8 @@
- *
- **************************************************************************/
-
-+#include <cstdlib>
-+
- #ifdef HAVE_CONFIG_H
- # include <config.h>
- #endif
-
diff --git a/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx b/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx
deleted file mode 100644
index d952a8d6441d..000000000000
--- a/games/flightgear/files/patch-src-AIModel-AIFlightPlanCreatePushBack.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/AIModel/AIFlightPlanCreatePushBack.cxx.orig 2012-04-29 00:33:37.069233986 +0300
-+++ src/AIModel/AIFlightPlanCreatePushBack.cxx 2012-04-29 00:33:57.598237572 +0300
-@@ -18,6 +18,8 @@
- *
- **************************************************************************/
-
-+#include <cstdlib>
-+
- #ifdef HAVE_CONFIG_H
- # include <config.h>
- #endif
-
diff --git a/games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx b/games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx
deleted file mode 100644
index 181fd2e809af..000000000000
--- a/games/flightgear/files/patch-src-ATCDCL-ATCutils.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ATCDCL/ATCutils.cxx.orig 2012-04-28 17:24:45.174236639 +0300
-+++ src/ATCDCL/ATCutils.cxx 2012-04-28 17:25:02.640237400 +0300
-@@ -23,6 +23,7 @@
- #endif
-
- #include <sstream>
-+#include <cstdlib>
-
- #include <simgear/math/SGMath.hxx>
- #include <simgear/constants.h>
-
diff --git a/games/flightgear/files/patch-src-Airports-runwayprefs.cxx b/games/flightgear/files/patch-src-Airports-runwayprefs.cxx
deleted file mode 100644
index 3ea13d8fbf70..000000000000
--- a/games/flightgear/files/patch-src-Airports-runwayprefs.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Airports/runwayprefs.cxx.orig 2012-04-28 17:05:44.544236696 +0300
-+++ src/Airports/runwayprefs.cxx 2012-04-28 17:06:08.564242690 +0300
-@@ -26,6 +26,7 @@
- #endif
-
- #include <math.h>
-+#include <cstdlib>
- #include <cstring>
-
- #include <simgear/compiler.h>
-
diff --git a/games/flightgear/files/patch-src-Autopilot-inputvalue.cxx b/games/flightgear/files/patch-src-Autopilot-inputvalue.cxx
deleted file mode 100644
index b21a20bb77ce..000000000000
--- a/games/flightgear/files/patch-src-Autopilot-inputvalue.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Autopilot/inputvalue.cxx.orig 2012-04-28 17:33:36.379238729 +0300
-+++ src/Autopilot/inputvalue.cxx 2012-04-28 17:33:54.516724154 +0300
-@@ -18,6 +18,8 @@
- // Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
- //
-
-+#include <cstdlib>
-+
- #include "inputvalue.hxx"
- #include <Main/fg_props.hxx>
- using namespace FGXMLAutopilot;
-
diff --git a/games/flightgear/files/patch-src-Canvas-ShivaVG-src-shDefs.h b/games/flightgear/files/patch-src-Canvas-ShivaVG-src-shDefs.h
new file mode 100644
index 000000000000..88b18b7f334c
--- /dev/null
+++ b/games/flightgear/files/patch-src-Canvas-ShivaVG-src-shDefs.h
@@ -0,0 +1,11 @@
+--- src/Canvas/ShivaVG/src/shDefs.h.orig 2012-08-28 17:51:24.000000000 +0200
++++ src/Canvas/ShivaVG/src/shDefs.h 2012-08-28 17:52:06.000000000 +0200
+@@ -34,7 +34,7 @@
+ #include <math.h>
+ #include <float.h>
+
+-#ifndef VG_API_MACOSX
++#if !defined(VG_API_MACOSX) && !defined(__FreeBSD__)
+ # include <malloc.h>
+ #endif
+
diff --git a/games/flightgear/files/patch-src-FDM-YASim-YASim.cxx b/games/flightgear/files/patch-src-FDM-YASim-YASim.cxx
deleted file mode 100644
index 5a4386025815..000000000000
--- a/games/flightgear/files/patch-src-FDM-YASim-YASim.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/FDM/YASim/YASim.cxx.orig 2012-04-30 11:28:08.392553266 +0300
-+++ src/FDM/YASim/YASim.cxx 2012-04-30 11:28:24.816555317 +0300
-@@ -3,6 +3,8 @@
- # include "config.h"
- #endif
-
-+#include <cstdlib>
-+
- #include <simgear/debug/logstream.hxx>
- #include <simgear/math/sg_geodesy.hxx>
- #include <simgear/misc/sg_path.hxx>
-
diff --git a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx
deleted file mode 100644
index 09b105da84b7..000000000000
--- a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Instrumentation/KLN89/kln89.cxx.orig 2012-04-28 19:44:36.140236845 +0300
-+++ src/Instrumentation/KLN89/kln89.cxx 2012-04-28 19:44:58.548236276 +0300
-@@ -1032,7 +1032,7 @@ void KLN89::DrawApt(int x, int y) {
- ++j;
- for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (i != x ? true : false));
- ++j;
-- for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (abs(i - x) > 1 ? true : false));
-+ for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (std::abs(i - x) > 1 ? true : false));
- ++j;
- for(i=x-2; i<=x+2; ++i) _instrument->DrawPixel(i, j, (i != x ? true : false));
- ++j;
-
diff --git a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx
deleted file mode 100644
index cdad2f72d7ec..000000000000
--- a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_cal.cxx
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Instrumentation/KLN89/kln89_page_cal.cxx.orig 2012-04-28 20:06:37.121237686 +0300
-+++ src/Instrumentation/KLN89/kln89_page_cal.cxx 2012-04-28 20:06:54.865235431 +0300
-@@ -21,6 +21,8 @@
- //
- // $Id$
-
-+#include <cstdlib>
-+
- #ifdef HAVE_CONFIG_H
- # include "config.h"
- #endif
-
diff --git a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx b/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx
deleted file mode 100644
index 16c155d3b4b0..000000000000
--- a/games/flightgear/files/patch-src-Instrumentation-KLN89-kln89_page_nav.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Instrumentation/KLN89/kln89_page_nav.cxx.orig 2012-04-30 17:00:03.000000000 +0200
-+++ src/Instrumentation/KLN89/kln89_page_nav.cxx 2012-04-30 17:03:56.000000000 +0200
-@@ -21,6 +21,8 @@
- //
- // $Id$
-
-+#include <cstdlib>
-+
- #ifdef HAVE_CONFIG_H
- # include "config.h"
- #endif
diff --git a/games/flightgear/files/patch-src-Instrumentation-dclgps.cxx b/games/flightgear/files/patch-src-Instrumentation-dclgps.cxx
deleted file mode 100644
index cd308966fde9..000000000000
--- a/games/flightgear/files/patch-src-Instrumentation-dclgps.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Instrumentation/dclgps.cxx.orig 2012-04-28 19:17:14.631235381 +0300
-+++ src/Instrumentation/dclgps.cxx 2012-04-28 19:17:34.070236096 +0300
-@@ -39,6 +39,7 @@
-
- #include <fstream>
- #include <iostream>
-+#include <cstdlib>
-
- using namespace std;
-
-
diff --git a/games/flightgear/files/patch-src-Network-ATC-Inputs.cxx b/games/flightgear/files/patch-src-Network-ATC-Inputs.cxx
deleted file mode 100644
index 098192a1c9c2..000000000000
--- a/games/flightgear/files/patch-src-Network-ATC-Inputs.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Network/ATC-Inputs.cxx.orig 2012-04-29 01:15:22.403234567 +0300
-+++ src/Network/ATC-Inputs.cxx 2012-04-29 01:16:16.046237193 +0300
-@@ -31,6 +31,7 @@
- # include <sys/types.h>
- # include <sys/stat.h>
- # include <fcntl.h>
-+# include <stdlib.h>
- # include <unistd.h>
- # include <istream>
- #endif
-
diff --git a/games/flightgear/files/patch-src-Network-ATC-Outputs.cxx b/games/flightgear/files/patch-src-Network-ATC-Outputs.cxx
deleted file mode 100644
index 22521ad5b800..000000000000
--- a/games/flightgear/files/patch-src-Network-ATC-Outputs.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Network/ATC-Outputs.cxx.orig 2012-04-29 01:16:36.569235929 +0300
-+++ src/Network/ATC-Outputs.cxx 2012-04-29 01:16:53.428236074 +0300
-@@ -31,6 +31,7 @@
- # include <sys/types.h>
- # include <sys/stat.h>
- # include <fcntl.h>
-+# include <stdlib.h>
- # include <unistd.h>
- # include <ostream>
- #endif
-
diff --git a/games/flightgear/files/patch-src-Network-AV400.cxx b/games/flightgear/files/patch-src-Network-AV400.cxx
deleted file mode 100644
index 8be5dfdd587f..000000000000
--- a/games/flightgear/files/patch-src-Network-AV400.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Network/AV400.cxx.orig 2012-04-29 01:21:15.898235552 +0300
-+++ src/Network/AV400.cxx 2012-04-29 01:21:32.302236489 +0300
-@@ -25,6 +25,7 @@
- # include "config.h"
- #endif
-
-+#include <cstdlib>
- #include <cstring>
-
- #include <simgear/debug/logstream.hxx>
-
diff --git a/games/flightgear/files/patch-src-Network-AV400Sim.cxx b/games/flightgear/files/patch-src-Network-AV400Sim.cxx
deleted file mode 100644
index 8fde1f46c414..000000000000
--- a/games/flightgear/files/patch-src-Network-AV400Sim.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Network/AV400Sim.cxx.orig 2012-04-29 01:21:53.059237359 +0300
-+++ src/Network/AV400Sim.cxx 2012-04-29 01:22:08.308236000 +0300
-@@ -29,6 +29,7 @@
- # include "config.h"
- #endif
-
-+#include <cstdlib>
- #include <cstring>
-
- #include <simgear/debug/logstream.hxx>
-
diff --git a/games/flightgear/files/patch-src-Network-atlas.cxx b/games/flightgear/files/patch-src-Network-atlas.cxx
deleted file mode 100644
index 2abe511a6b9e..000000000000
--- a/games/flightgear/files/patch-src-Network-atlas.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Network/atlas.cxx.orig 2012-04-29 11:25:56.839235311 +0300
-+++ src/Network/atlas.cxx 2012-04-29 11:26:08.073235344 +0300
-@@ -24,6 +24,7 @@
- # include "config.h"
- #endif
-
-+#include <cstdlib>
- #include <cstring>
-
- #include <simgear/debug/logstream.hxx>
-
diff --git a/games/flightgear/files/patch-src-Network-garmin.cxx b/games/flightgear/files/patch-src-Network-garmin.cxx
deleted file mode 100644
index b3c73112f10c..000000000000
--- a/games/flightgear/files/patch-src-Network-garmin.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Network/garmin.cxx.orig 2012-04-29 11:43:22.790235105 +0300
-+++ src/Network/garmin.cxx 2012-04-29 11:43:38.200345541 +0300
-@@ -25,6 +25,7 @@
- #endif
-
- #include <iostream>
-+#include <cstdlib>
- #include <cstring>
-
- #include <simgear/debug/logstream.hxx>
-
diff --git a/games/flightgear/files/patch-src-Network-nmea.cxx b/games/flightgear/files/patch-src-Network-nmea.cxx
deleted file mode 100644
index ca10856b74fa..000000000000
--- a/games/flightgear/files/patch-src-Network-nmea.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Network/nmea.cxx.orig 2012-04-29 11:44:11.629236922 +0300
-+++ src/Network/nmea.cxx 2012-04-29 11:44:22.384235831 +0300
-@@ -24,6 +24,7 @@
- # include "config.h"
- #endif
-
-+#include <cstdlib>
- #include <cstring>
-
- #include <simgear/debug/logstream.hxx>
-
diff --git a/games/flightgear/files/patch-src-Systems-electrical.cxx b/games/flightgear/files/patch-src-Systems-electrical.cxx
deleted file mode 100644
index 5567382a39f5..000000000000
--- a/games/flightgear/files/patch-src-Systems-electrical.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Systems/electrical.cxx.orig 2012-04-30 10:16:40.139557199 +0300
-+++ src/Systems/electrical.cxx 2012-04-30 10:16:50.765555099 +0300
-@@ -24,6 +24,7 @@
- # include <config.h>
- #endif
-
-+#include <cstdlib>
- #include <cstring>
-
- #include <simgear/structure/exception.hxx>
-
diff --git a/games/flightgear/files/patch-src-Systems-system_mgr.cxx b/games/flightgear/files/patch-src-Systems-system_mgr.cxx
deleted file mode 100644
index 91937bf14b52..000000000000
--- a/games/flightgear/files/patch-src-Systems-system_mgr.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Systems/system_mgr.cxx.orig 2012-04-30 10:59:27.756554918 +0300
-+++ src/Systems/system_mgr.cxx 2012-04-30 10:59:44.991555084 +0300
-@@ -16,6 +16,7 @@
- #include <Main/globals.hxx>
- #include <Main/util.hxx>
-
-+#include <cstdlib>
- #include <iostream>
- #include <string>
- #include <sstream>
-
diff --git a/games/flightgear/pkg-plist b/games/flightgear/pkg-plist
index 24131eba1ed9..5a5d06292a30 100644
--- a/games/flightgear/pkg-plist
+++ b/games/flightgear/pkg-plist
@@ -6,6 +6,7 @@ bin/fgjs
bin/metar
bin/terrasync
bin/yasim
+bin/yasim-proptest
bin/GPSsmooth
bin/MIDGsmooth
bin/UGsmooth