aboutsummaryrefslogtreecommitdiff
path: root/games/gemrb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gemrb/Makefile')
-rw-r--r--games/gemrb/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/games/gemrb/Makefile b/games/gemrb/Makefile
index e544adc0b538..33c5e4e4ef6f 100644
--- a/games/gemrb/Makefile
+++ b/games/gemrb/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gemrb
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= games emulators
MASTER_SITES= SF/${PORTNAME}/GemRB%20Sources/GemRB%20${PORTVERSION}%20Sources
@@ -14,7 +15,7 @@ MAINTAINER= beyert@cs.ucr.edu
COMMENT= GemRB (Game engine made with preRendered Background)
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
- vorbis.4:${PORTSDIR}/audio/libvorbis
+ vorbis.4:${PORTSDIR}/audio/libvorbis
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -23,7 +24,7 @@ USE_CMAKE= yes
USE_SDL= sdl mixer
USE_OPENAL= al alut
USE_LDCONFIG= yes
-USE_PYTHON= 2.4+
+USE_PYTHON= 2.5+
CFLAGS+= -L${LOCALBASE}/lib -I${LOCALBASE}/include
CMAKE_C_FLAGS= ${CFLAGS}
CMAKE_ARGS= -DDOC_DIR="${LOCALBASE}/share/doc/gemrb" -DMAN_DIR="${LOCALBASE}/man/man6" -DDISABLE_WERROR=1
@@ -32,10 +33,6 @@ MAN6= gemrb.6
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not build on 6.X
-.endif
-
post-patch:
.if defined(NOPORTDOCS)
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-noportdocs-*