aboutsummaryrefslogtreecommitdiff
path: root/games/gnurobbo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/gnurobbo/Makefile')
-rw-r--r--games/gnurobbo/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/gnurobbo/Makefile b/games/gnurobbo/Makefile
new file mode 100644
index 000000000000..211c99282e9f
--- /dev/null
+++ b/games/gnurobbo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gnurobbo
+# Date created: 05 Mar 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnurobbo
+PORTVERSION= 0.61
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Reimplementation of LK Avalon's Robbo for the Atari XE/XL
+
+USE_GMAKE= yes
+USE_SDL= sdl ttf
+
+MAKE_ENV= DATADIR="${DATADIR}" DOCSDIR="${DOCSDIR}"
+
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e '/define DEBUG_DUMP_VM_USAGE/ d' ${WRKSRC}/game.c
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/DOCDIR/ d' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>