aboutsummaryrefslogtreecommitdiff
path: root/games/iortcw/files/patch-MP_Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/iortcw/files/patch-MP_Makefile')
-rw-r--r--games/iortcw/files/patch-MP_Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/games/iortcw/files/patch-MP_Makefile b/games/iortcw/files/patch-MP_Makefile
index be11bab35ea7..195d8804563a 100644
--- a/games/iortcw/files/patch-MP_Makefile
+++ b/games/iortcw/files/patch-MP_Makefile
@@ -1,5 +1,16 @@
--- MP/Makefile.orig 2019-03-16 18:09:48 UTC
+++ MP/Makefile
+@@ -5,8 +5,8 @@ COMPILE_PLATFORM=$(shell uname | sed -e 's/_.*//' | tr
+ #
+
+ COMPILE_PLATFORM=$(shell uname | sed -e 's/_.*//' | tr '[:upper:]' '[:lower:]' | sed -e 's/\//_/g')
+-COMPILE_ARCH=$(shell uname -m | sed -e 's/i.86/x86/' | sed -e 's/^arm.*/arm/')
+-ARM_VER_CHECK=$(shell uname -m)
++COMPILE_ARCH=$(shell uname -p | sed -e 's/i.86/x86/' | sed -e 's/^arm.*/arm/')
++ARM_VER_CHECK=$(shell uname -p)
+
+ ifeq ($(COMPILE_PLATFORM),sunos)
+ # Solaris uname and GNU uname differ
@@ -101,14 +101,6 @@ export ARCH
endif
export ARCH