aboutsummaryrefslogtreecommitdiff
path: root/games/jumpy/Makefile.crates
diff options
context:
space:
mode:
Diffstat (limited to 'games/jumpy/Makefile.crates')
-rw-r--r--games/jumpy/Makefile.crates201
1 files changed, 111 insertions, 90 deletions
diff --git a/games/jumpy/Makefile.crates b/games/jumpy/Makefile.crates
index e16c63c9a3cc..b7241813f061 100644
--- a/games/jumpy/Makefile.crates
+++ b/games/jumpy/Makefile.crates
@@ -1,4 +1,4 @@
-CARGO_CRATES= ab_glyph-0.2.22 \
+CARGO_CRATES= ab_glyph-0.2.23 \
ab_glyph_rasterizer-0.1.8 \
accesskit-0.11.2 \
accesskit_consumer-0.15.2 \
@@ -7,7 +7,7 @@ CARGO_CRATES= ab_glyph-0.2.22 \
accesskit_winit-0.14.4 \
addr2line-0.21.0 \
adler-1.0.2 \
- ahash-0.8.3 \
+ ahash-0.8.6 \
aho-corasick-1.1.2 \
allocator-api2-0.2.16 \
alsa-0.7.1 \
@@ -19,19 +19,19 @@ CARGO_CRATES= ab_glyph-0.2.22 \
anyhow-1.0.75 \
append-only-vec-0.1.3 \
approx-0.5.1 \
- arboard-3.2.1 \
+ arboard-3.3.0 \
arrayref-0.3.7 \
arrayvec-0.7.4 \
ash-0.37.3+1.3.251 \
async-channel-1.9.0 \
- async-executor-1.6.0 \
- async-lock-2.8.0 \
+ async-executor-1.8.0 \
+ async-lock-3.2.0 \
async-task-4.5.0 \
atomic-arena-0.1.1 \
- atomicell-0.1.9 \
+ atomicell-0.2.0 \
autocfg-1.1.0 \
backtrace-0.3.69 \
- base64-0.21.4 \
+ base64-0.21.5 \
bevy-0.11.3 \
bevy_a11y-0.11.3 \
bevy_app-0.11.3 \
@@ -43,6 +43,7 @@ CARGO_CRATES= ab_glyph-0.2.22 \
bevy_dylib-0.11.3 \
bevy_ecs-0.11.3 \
bevy_ecs_macros-0.11.3 \
+ bevy_egui-0.22.0 \
bevy_encase_derive-0.11.3 \
bevy_gilrs-0.11.3 \
bevy_gizmos-0.11.3 \
@@ -69,7 +70,7 @@ CARGO_CRATES= ab_glyph-0.2.22 \
bevy_utils_proc_macros-0.11.3 \
bevy_window-0.11.3 \
bevy_winit-0.11.3 \
- bindgen-0.68.1 \
+ bindgen-0.69.1 \
bit-set-0.5.3 \
bit-vec-0.6.3 \
bitflags-1.3.2 \
@@ -99,19 +100,19 @@ CARGO_CRATES= ab_glyph-0.2.22 \
color_quant-1.1.0 \
com-rs-0.2.1 \
combine-4.6.6 \
- concurrent-queue-2.3.0 \
+ concurrent-queue-2.4.0 \
console_error_panic_hook-0.1.7 \
const_panic-0.2.8 \
const_soft_float-0.1.4 \
constgebra-0.1.3 \
- core-foundation-0.9.3 \
- core-foundation-sys-0.8.4 \
+ core-foundation-0.9.4 \
+ core-foundation-sys-0.8.6 \
core-graphics-0.22.3 \
- core-graphics-types-0.1.2 \
+ core-graphics-types-0.1.3 \
coreaudio-rs-0.11.3 \
- coreaudio-sys-0.2.13 \
+ coreaudio-sys-0.2.14 \
cpal-0.15.2 \
- cpufeatures-0.2.9 \
+ cpufeatures-0.2.11 \
crc32fast-1.3.2 \
crossbeam-0.8.2 \
crossbeam-channel-0.5.8 \
@@ -124,9 +125,8 @@ CARGO_CRATES= ab_glyph-0.2.22 \
d3d12-0.6.0 \
dashmap-5.5.3 \
dasp_sample-0.11.0 \
- data-encoding-2.4.0 \
+ data-encoding-2.5.0 \
digest-0.10.7 \
- directories-1.0.2 \
directories-5.0.1 \
dirs-sys-0.4.1 \
dispatch-0.2.0 \
@@ -139,13 +139,14 @@ CARGO_CRATES= ab_glyph-0.2.22 \
egui_extras-0.23.0 \
ehttp-0.3.1 \
either-1.9.0 \
+ elsa-1.9.0 \
emath-0.23.0 \
encase-0.6.1 \
encase_derive-0.6.1 \
encase_derive_impl-0.6.1 \
encoding_rs-0.8.33 \
- enum-map-2.6.3 \
- enum-map-derive-0.14.0 \
+ enum-map-2.7.3 \
+ enum-map-derive-0.17.0 \
enumn-0.1.12 \
epaint-0.23.0 \
equivalent-1.0.1 \
@@ -153,14 +154,16 @@ CARGO_CRATES= ab_glyph-0.2.22 \
error-code-2.3.1 \
euclid-0.22.9 \
event-listener-2.5.3 \
- event-listener-3.0.0 \
+ event-listener-3.1.0 \
+ event-listener-4.0.0 \
+ event-listener-strategy-0.4.0 \
fastrand-1.9.0 \
fastrand-2.0.1 \
- fdeflate-0.3.0 \
- filetime-0.2.22 \
+ fdeflate-0.3.1 \
+ filetime-0.2.23 \
fixedbitset-0.4.2 \
flate2-1.0.28 \
- float_next_after-0.1.5 \
+ float_next_after-1.0.0 \
fluent-0.15.0 \
fluent-bundle-0.15.2 \
fluent-langneg-0.13.0 \
@@ -168,20 +171,21 @@ CARGO_CRATES= ab_glyph-0.2.22 \
fnv-1.0.7 \
foreign-types-0.3.2 \
foreign-types-shared-0.1.1 \
- form_urlencoded-1.2.0 \
+ form_urlencoded-1.2.1 \
fsevent-sys-4.1.0 \
funty-2.0.0 \
- futures-core-0.3.28 \
- futures-io-0.3.28 \
+ futures-core-0.3.29 \
+ futures-io-0.3.29 \
futures-lite-1.13.0 \
+ futures-lite-2.1.0 \
fxhash-0.2.1 \
generic-array-0.14.7 \
- gethostname-0.2.3 \
+ gethostname-0.3.0 \
getrandom-0.1.16 \
- getrandom-0.2.10 \
+ getrandom-0.2.11 \
gilrs-0.10.2 \
gilrs-core-0.5.7 \
- gimli-0.28.0 \
+ gimli-0.28.1 \
glam-0.24.2 \
glob-0.3.1 \
glow-0.12.3 \
@@ -192,7 +196,7 @@ CARGO_CRATES= ab_glyph-0.2.22 \
gpu-descriptor-types-0.1.2 \
guillotiere-0.6.2 \
hashbrown-0.12.3 \
- hashbrown-0.14.2 \
+ hashbrown-0.14.3 \
hassle-rs-0.10.0 \
hex-0.4.3 \
hexasphere-9.1.0 \
@@ -200,10 +204,10 @@ CARGO_CRATES= ab_glyph-0.2.22 \
home-0.5.5 \
humantime-2.1.0 \
humantime-serde-1.1.1 \
- idna-0.4.0 \
+ idna-0.5.0 \
image-0.24.7 \
indexmap-1.9.3 \
- indexmap-2.0.2 \
+ indexmap-2.1.0 \
inotify-0.9.6 \
inotify-sys-0.1.5 \
instant-0.1.12 \
@@ -218,24 +222,26 @@ CARGO_CRATES= ab_glyph-0.2.22 \
jni-sys-0.3.0 \
jobserver-0.1.27 \
jpeg-decoder-0.3.0 \
- js-sys-0.3.64 \
+ js-sys-0.3.66 \
khronos-egl-4.1.0 \
kqueue-1.0.8 \
kqueue-sys-1.0.4 \
lazy_static-1.4.0 \
lazycell-1.3.0 \
- libc-0.2.149 \
+ libc-0.2.150 \
libloading-0.7.4 \
libloading-0.8.1 \
libm-0.2.8 \
+ libredox-0.0.1 \
+ libredox-0.0.2 \
libudev-sys-0.1.4 \
litrs-0.2.3 \
lock_api-0.4.11 \
log-0.4.20 \
- lyon_algorithms-1.0.3 \
+ lyon_algorithms-1.0.4 \
lyon_geom-1.0.4 \
lyon_path-1.0.4 \
- lyon_tessellation-1.0.10 \
+ lyon_tessellation-1.0.12 \
mach2-0.4.1 \
malloc_buf-0.0.6 \
matchers-0.1.0 \
@@ -244,12 +250,13 @@ CARGO_CRATES= ab_glyph-0.2.22 \
memchr-2.6.4 \
memmap2-0.5.10 \
memoffset-0.6.5 \
+ memoffset-0.7.1 \
memoffset-0.9.0 \
metal-0.24.0 \
minimal-lexical-0.2.1 \
miniz_oxide-0.7.1 \
mint-0.5.9 \
- mio-0.8.8 \
+ mio-0.8.10 \
naga-0.12.3 \
naga_oil-0.8.2 \
nalgebra-0.32.3 \
@@ -285,13 +292,13 @@ CARGO_CRATES= ab_glyph-0.2.22 \
object-0.32.1 \
oboe-0.5.0 \
oboe-sys-0.5.0 \
- once_cell-1.18.0 \
+ once_cell-1.19.0 \
+ once_map-0.4.13 \
option-ext-0.2.0 \
- optional-0.5.0 \
- orbclient-0.3.46 \
+ orbclient-0.3.47 \
ordered-float-3.9.2 \
overload-0.1.1 \
- owned_ttf_parser-0.19.0 \
+ owned_ttf_parser-0.20.0 \
parking-2.2.0 \
parking_lot-0.12.1 \
parking_lot_core-0.9.9 \
@@ -303,7 +310,7 @@ CARGO_CRATES= ab_glyph-0.2.22 \
peg-0.8.2 \
peg-macros-0.8.2 \
peg-runtime-0.8.2 \
- percent-encoding-2.3.0 \
+ percent-encoding-2.3.1 \
petgraph-0.6.4 \
phf-0.11.2 \
phf_generator-0.11.2 \
@@ -315,7 +322,7 @@ CARGO_CRATES= ab_glyph-0.2.22 \
pp-rs-0.2.1 \
ppv-lite86-0.2.17 \
proc-macro-crate-1.3.1 \
- proc-macro2-1.0.69 \
+ proc-macro2-1.0.70 \
profiling-1.0.11 \
puffin-0.16.0 \
quote-1.0.33 \
@@ -334,37 +341,38 @@ CARGO_CRATES= ab_glyph-0.2.22 \
raw-window-handle-0.5.2 \
rawpointer-0.2.1 \
rectangle-pack-0.4.2 \
- redox_syscall-0.2.16 \
redox_syscall-0.3.5 \
redox_syscall-0.4.1 \
- redox_users-0.4.3 \
+ redox_users-0.4.4 \
regex-1.10.2 \
regex-automata-0.1.10 \
regex-automata-0.4.3 \
regex-syntax-0.6.29 \
regex-syntax-0.8.2 \
renderdoc-sys-1.0.0 \
- ring-0.16.20 \
+ ring-0.17.7 \
ringbuf-0.3.3 \
- robust-0.2.3 \
+ robust-1.1.0 \
ron-0.8.1 \
rustc-demangle-0.1.23 \
rustc-hash-1.1.0 \
- rustls-0.21.7 \
- rustls-webpki-0.101.6 \
+ rustls-0.21.10 \
+ rustls-webpki-0.101.7 \
ryu-1.0.15 \
safe_arch-0.7.1 \
same-file-1.0.6 \
scoped-tls-1.0.1 \
scopeguard-1.2.0 \
- sct-0.7.0 \
+ sct-0.7.1 \
sctk-adwaita-0.5.4 \
- self_cell-0.10.2 \
+ self_cell-0.10.3 \
+ self_cell-1.0.2 \
semver-1.0.20 \
- serde-1.0.189 \
- serde_derive-1.0.189 \
- serde_json-1.0.107 \
- serde_yaml-0.9.25 \
+ send_wrapper-0.6.0 \
+ serde-1.0.193 \
+ serde_derive-1.0.193 \
+ serde_json-1.0.108 \
+ serde_yaml-0.9.27 \
sha2-0.10.8 \
sharded-slab-0.1.7 \
shiftnanigans-0.3.3 \
@@ -373,14 +381,15 @@ CARGO_CRATES= ab_glyph-0.2.22 \
simd-adler32-0.3.7 \
siphasher-0.3.11 \
slab-0.4.9 \
- slotmap-1.0.6 \
- smallvec-1.11.1 \
+ slotmap-1.0.7 \
+ smallvec-1.11.2 \
smithay-client-toolkit-0.16.1 \
smol_str-0.2.0 \
- spade-2.2.0 \
- spin-0.5.2 \
+ spade-2.4.1 \
+ spin-0.9.8 \
spirv-0.2.0+1.5.4 \
sptr-0.3.2 \
+ stable_deref_trait-1.2.0 \
static_assertions-1.1.0 \
str-buf-1.0.6 \
strict-num-0.1.1 \
@@ -393,46 +402,48 @@ CARGO_CRATES= ab_glyph-0.2.22 \
symphonia-metadata-0.5.3 \
symphonia-utils-xiph-0.5.3 \
syn-1.0.109 \
- syn-2.0.38 \
+ syn-2.0.39 \
+ synstructure-0.13.0 \
sys-locale-0.3.1 \
- sysinfo-0.29.10 \
+ sysinfo-0.29.11 \
tap-1.0.1 \
- termcolor-1.3.0 \
+ termcolor-1.4.0 \
thiserror-1.0.50 \
thiserror-impl-1.0.50 \
thread_local-1.1.7 \
tiff-0.9.0 \
tiny-skia-0.8.4 \
tiny-skia-path-0.8.4 \
- tinystr-0.7.4 \
+ tinystr-0.7.5 \
tinyvec-1.6.0 \
tinyvec_macros-0.1.1 \
- toml_datetime-0.6.3 \
+ toml_datetime-0.6.5 \
toml_edit-0.19.15 \
tracing-0.1.40 \
tracing-attributes-0.1.27 \
tracing-core-0.1.32 \
- tracing-log-0.1.3 \
- tracing-subscriber-0.3.17 \
+ tracing-log-0.1.4 \
+ tracing-log-0.2.0 \
+ tracing-subscriber-0.3.18 \
tracing-wasm-0.2.1 \
- ttf-parser-0.19.2 \
+ ttf-parser-0.20.0 \
turborand-0.10.0 \
type-map-0.4.0 \
typenum-1.17.0 \
ulid-1.1.0 \
- unic-langid-0.9.1 \
- unic-langid-impl-0.9.1 \
- unicode-bidi-0.3.13 \
+ unic-langid-0.9.3 \
+ unic-langid-impl-0.9.3 \
+ unicode-bidi-0.3.14 \
unicode-ident-1.0.12 \
unicode-normalization-0.1.22 \
unicode-width-0.1.11 \
unicode-xid-0.2.4 \
unsafe-libyaml-0.2.9 \
- untrusted-0.7.1 \
- ureq-2.8.0 \
- url-2.4.1 \
+ untrusted-0.9.0 \
+ ureq-2.9.1 \
+ url-2.5.0 \
ustr-0.10.0 \
- uuid-1.5.0 \
+ uuid-1.6.1 \
valuable-0.1.0 \
vec_map-0.8.2 \
venial-0.5.0 \
@@ -441,21 +452,21 @@ CARGO_CRATES= ab_glyph-0.2.22 \
walkdir-2.4.0 \
wasi-0.9.0+wasi-snapshot-preview1 \
wasi-0.11.0+wasi-snapshot-preview1 \
- wasm-bindgen-0.2.87 \
- wasm-bindgen-backend-0.2.87 \
- wasm-bindgen-futures-0.4.37 \
- wasm-bindgen-macro-0.2.87 \
- wasm-bindgen-macro-support-0.2.87 \
- wasm-bindgen-shared-0.2.87 \
+ wasm-bindgen-0.2.89 \
+ wasm-bindgen-backend-0.2.89 \
+ wasm-bindgen-futures-0.4.39 \
+ wasm-bindgen-macro-0.2.89 \
+ wasm-bindgen-macro-support-0.2.89 \
+ wasm-bindgen-shared-0.2.89 \
wayland-client-0.29.5 \
wayland-commons-0.29.5 \
wayland-cursor-0.29.5 \
wayland-protocols-0.29.5 \
wayland-scanner-0.29.5 \
wayland-sys-0.29.5 \
- web-sys-0.3.64 \
+ web-sys-0.3.66 \
webbrowser-0.8.12 \
- webpki-roots-0.25.2 \
+ webpki-roots-0.25.3 \
weezl-0.1.7 \
wgpu-0.16.3 \
wgpu-core-0.16.1 \
@@ -471,36 +482,46 @@ CARGO_CRATES= ab_glyph-0.2.22 \
windows-0.44.0 \
windows-0.46.0 \
windows-0.48.0 \
- windows-0.51.1 \
- windows-core-0.51.1 \
windows-implement-0.48.0 \
windows-interface-0.48.0 \
windows-sys-0.45.0 \
windows-sys-0.48.0 \
+ windows-sys-0.52.0 \
windows-targets-0.42.2 \
windows-targets-0.48.5 \
+ windows-targets-0.52.0 \
windows_aarch64_gnullvm-0.42.2 \
windows_aarch64_gnullvm-0.48.5 \
+ windows_aarch64_gnullvm-0.52.0 \
windows_aarch64_msvc-0.42.2 \
windows_aarch64_msvc-0.48.5 \
+ windows_aarch64_msvc-0.52.0 \
windows_i686_gnu-0.42.2 \
windows_i686_gnu-0.48.5 \
+ windows_i686_gnu-0.52.0 \
windows_i686_msvc-0.42.2 \
windows_i686_msvc-0.48.5 \
+ windows_i686_msvc-0.52.0 \
windows_x86_64_gnu-0.42.2 \
windows_x86_64_gnu-0.48.5 \
+ windows_x86_64_gnu-0.52.0 \
windows_x86_64_gnullvm-0.42.2 \
windows_x86_64_gnullvm-0.48.5 \
+ windows_x86_64_gnullvm-0.52.0 \
windows_x86_64_msvc-0.42.2 \
windows_x86_64_msvc-0.48.5 \
+ windows_x86_64_msvc-0.52.0 \
winit-0.28.7 \
- winnow-0.5.17 \
+ winnow-0.5.26 \
wyz-0.5.1 \
x11-dl-2.21.0 \
- x11rb-0.10.1 \
- x11rb-protocol-0.10.0 \
- xcursor-0.3.4 \
+ x11rb-0.12.0 \
+ x11rb-protocol-0.12.0 \
+ xcursor-0.3.5 \
xml-rs-0.8.19 \
- bones_asset,bones_bevy_renderer,bones_ecs,bones_framework,bones_lib,bones_schema,bones_schema_macros,bones_utils,bones_utils_macros@git+https://github.com/fishfolk/bones\#3fd1ace195e2a9ac684c247cd08995b3e5a5b93b \
- bevy_egui@git+https://github.com/zicklag/bevy_egui?branch=feat/egui-0.23\#aeb3d7f1eaaacc67cf3966974d1e31f31e8fad62 \
- kira@git+https://github.com/zicklag/kira.git?branch=feat/sync\#e587b155e862567677c114d0d6fc2963be37c14b
+ zerocopy-0.7.30 \
+ zerocopy-derive-0.7.30 \
+ kira@git+https://github.com/zicklag/kira.git?branch=feat/sync\#ff184e31263652e21d94445b9087dfee04c2ea2b \
+ bones_asset,bones_bevy_renderer,bones_ecs,bones_framework,bones_lib,bones_schema,bones_schema_macros,bones_scripting,bones_utils,bones_utils_macros@git+https://github.com/fishfolk/bones\#831a7d83bd427fd89e5bc4de5386089245bf2fff \
+ gc-arena,gc-arena-derive@git+https://github.com/kyren/gc-arena\#bdb328467fb062c8d904cb4ce4d725e2ad816580 \
+ piccolo@git+https://github.com/kyren/piccolo.git?rev=d25ef38\#d25ef38068229c96e24704fe499e412d0bef6e84