aboutsummaryrefslogtreecommitdiff
path: root/games/kartofel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/kartofel/Makefile')
-rw-r--r--games/kartofel/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/games/kartofel/Makefile b/games/kartofel/Makefile
index a821717911a9..afc872624c1b 100644
--- a/games/kartofel/Makefile
+++ b/games/kartofel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: kartofel
-# Date created: 19 Jan 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= kartofel
PORTVERSION= 1.2
@@ -15,7 +11,7 @@ MASTER_SITES= http://kartofel.jfedor.org/downloads/ \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Connect the dots in order without crossing over yourself
-LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
USE_GMAKE= yes
USE_SDL= sdl gfx mixer image ttf
@@ -25,6 +21,9 @@ MAKE_JOBS_SAFE= yes
DATA_DIRS= sounds fonts music images levels
+PLIST_FILES= bin/${PORTNAME}
+PORTDATA= *
+
DESKTOP_ENTRIES="Kartofel" \
"A game of skill and logic" \
"${DATADIR}/images/icon32x32.png" \
@@ -41,7 +40,9 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/kartofel ${PREFIX}/bin
+.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATA_DIRS}" ${DATADIR}
+.endif
.include <bsd.port.mk>