aboutsummaryrefslogtreecommitdiff
path: root/games/libretro-prboom/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/libretro-prboom/Makefile')
-rw-r--r--games/libretro-prboom/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/games/libretro-prboom/Makefile b/games/libretro-prboom/Makefile
new file mode 100644
index 000000000000..37932ed846e3
--- /dev/null
+++ b/games/libretro-prboom/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libretro-prboom
+PORTVERSION= 0.20200313
+CATEGORIES= games
+
+MAINTAINER= menelkir@itroll.org
+COMMENT= Port of prboom to libretro
+
+LICENSE= GPLv2
+
+USES= compiler:c++11-lib gmake
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= libretro
+GH_TAGNAME= 991016b
+
+PLIST_FILES= libexec/libretro/prboom_libretro.so
+
+do-install:
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/libexec/libretro;
+ ${INSTALL_LIB} $$(find ${WRKSRC}/${COREDIR}/ -name "*.so") ${STAGEDIR}/${PREFIX}/libexec/libretro;
+
+.include <bsd.port.mk>