aboutsummaryrefslogtreecommitdiff
path: root/games/linux-x-plane/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/linux-x-plane/Makefile')
-rw-r--r--games/linux-x-plane/Makefile67
1 files changed, 55 insertions, 12 deletions
diff --git a/games/linux-x-plane/Makefile b/games/linux-x-plane/Makefile
index 78b45fa026ba..1869a3ddf2b2 100644
--- a/games/linux-x-plane/Makefile
+++ b/games/linux-x-plane/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= linux-x-plane
-PORTVERSION= 8.16
+PORTVERSION= 8.20
CATEGORIES= games linux
-MASTER_SITES= http://66.111.223.52/ \
- ftp://ftp.x-plane.com/Web_Links/
-DISTNAME= XLIN${XPVERSION}b
+MASTER_SITES= # empty
MAINTAINER= jylefort@FreeBSD.org
COMMENT= A commercial flight simulator
@@ -19,28 +17,27 @@ RUN_DEPENDS= ${LINUXBASE}/lib/libgcc/libgcc_s.so.1:${PORTSDIR}/lang/linux-libgcc
${LINUXBASE}/usr/lib/libopenal.so.0:${PORTSDIR}/audio/linux-openal \
${LINUXBASE}/usr/X11R6/lib/libGLU.so.1.3:${PORTSDIR}/graphics/linux_dri
-WRKSRC= ${WRKDIR}/X-System-${XPVERSION}-lin1
+IGNOREFILES= ${DISTFILES} # user-created distribution
+NO_WRKSUBDIR= yes
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_LINUX= yes
NO_BUILD= yes
RESTRICTED= "Redistribution prohibited"
-NO_PACKAGE= "Package will be 353 MB, set FORCE_PACKAGE if you really want to build it"
+NO_PACKAGE= "Package will be 348 MB, set FORCE_PACKAGE if you really want to build it"
ONLY_FOR_ARCHS= i386 amd64
-XPVERSION= ${PORTVERSION:S|.||g}
-
XDIR= ${PREFIX}/lib/x-plane
XDIR_REL= ${XDIR:S,^${PREFIX}/,,}
PROGRAMS= Airfoil-Maker Briefer Plane-Maker World-Maker X-Plane
-PLIST= ${WRKDIR}/pkg-plist
+PLIST= ${WRKDIR}/.plist
PLIST_FILES= ${PROGRAMS:S|^|bin/|} libexec/x-plane-wrapper
PLIST_DIRS= ${XDIR_REL}
SUB_FILES= x-plane-wrapper
-SUB_LIST= XDIR="${XDIR}" PORTVERSION="${PORTVERSION}" XPVERSION="${XPVERSION}"
+SUB_LIST= XDIR="${XDIR}" PORTVERSION="${PORTVERSION}" PROGRAMS="${PROGRAMS}"
DESKTOP_ENTRIES="X-Plane Airfoil Maker" \
"Edit X-Plane airfoils" \
@@ -89,6 +86,51 @@ RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_d
RUN_DEPENDS+= ${LINUXBASE}/lib/libGL.so.1:${PORTSDIR}/graphics/linux_glx
.endif
+do-fetch:
+ @if ! [ -e ${DISTDIR}/${DISTFILES} ]; then \
+ ${ECHO_CMD} "" ; \
+ ${ECHO_CMD} "The X-Plane distribution must be manually fetched with the X-Plane installer." ; \
+ ${ECHO_CMD} "To fetch the X-Plane distribution and create a tarball (for personal use only;" ; \
+ ${ECHO_CMD} "redistribution prohibited by license), do the following:" ; \
+ ${ECHO_CMD} "" ; \
+ ${ECHO_CMD} " - install the games/linux-x-plane-net-installer port" ; \
+ ${ECHO_CMD} " - as a normal user, run X-Plane-Net-Install, select a destination directory" ; \
+ ${ECHO_CMD} " with enough free space (you need about 550 MB), and install X-Plane" ; \
+ ${ECHO_CMD} " - as root, create the distribution tarball:" ; \
+ ${ECHO_CMD} "" ; \
+ ${ECHO_CMD} " cd ${MASTERDIR}" ; \
+ ${ECHO_CMD} " make dist XDISTDIR=/path/where/xplane/was/installed" ; \
+ ${ECHO_CMD} "" ; \
+ ${ECHO_CMD} "You can then remove XDISTDIR and install this port normally." ; \
+ ${ECHO_CMD} "" ; \
+ ${FALSE} ; \
+ fi
+
+dist:
+.if defined(XDISTDIR)
+. if exists(${XDISTDIR}/X-Plane-athlon-xp) \
+ || exists(${XDISTDIR}/X-Plane-i586) \
+ || exists(${XDISTDIR}/X-Plane-pentium-3)
+ @${ECHO_MSG} "===> Packaging ${XDISTDIR} into ${DISTDIR}/${DISTFILES}"
+ @cd ${XDISTDIR} && ${TAR} -ycf ${DISTDIR}/${DISTFILES} *
+. else
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "${XDISTDIR} does not appear to contain the X-Plane ${PORTVERSION} distribution."
+ @${ECHO_CMD} ""
+ @${FALSE}
+. endif
+.else
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "XDISTDIR not defined."
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} "You must point XDISTDIR to the path where you have installed the X-Plane"
+ @${ECHO_CMD} "distribution with the installer, for instance:"
+ @${ECHO_CMD} ""
+ @${ECHO_CMD} " make dist XDISTDIR=/tmp/X-Plane"
+ @${ECHO_CMD} ""
+ @${FALSE}
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -type d -empty -exec ${TOUCH} "{}/.keep_me" \;
@${MKDIR} ${WRKSRC}/.programs/Resources
@@ -98,6 +140,8 @@ post-patch:
.endfor
pre-install:
+ @${MKDIR} ${WRKDIR}/.wrapper
+ @${MV} -f ${WRKDIR}/x-plane-wrapper ${WRKDIR}/.wrapper
@${RM} -f ${PLIST}
@${RM} -f ${PLIST}.dirs
.for d in "" .programs
@@ -108,7 +152,7 @@ pre-install:
@${SORT} -ru ${PLIST}.dirs | ${SED} -e 's|^|@dirrm ${XDIR_REL}/|' >> ${PLIST}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/x-plane-wrapper ${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKDIR}/.wrapper/x-plane-wrapper ${PREFIX}/libexec
.for p in ${PROGRAMS}
${LN} -sf ${PREFIX}/libexec/x-plane-wrapper ${PREFIX}/bin/${p}
.endfor
@@ -117,6 +161,5 @@ do-install:
.endfor
cd ${WRKSRC} && ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${XDIR}/{}" \;
cd ${WRKSRC}/.programs && ${FIND} * -type f -exec ${INSTALL_PROGRAM} "{}" "${XDIR}/{}" \;
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>