aboutsummaryrefslogtreecommitdiff
path: root/games/openarena-oax
diff options
context:
space:
mode:
Diffstat (limited to 'games/openarena-oax')
-rw-r--r--games/openarena-oax/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/games/openarena-oax/Makefile b/games/openarena-oax/Makefile
index f7282f54a278..f2f10f822e66 100644
--- a/games/openarena-oax/Makefile
+++ b/games/openarena-oax/Makefile
@@ -25,9 +25,11 @@ NO_BUILD= yes
OABASE= ${DISTNAME}
+post-extract:
+ ${UNZIP_CMD} -j ${DISTDIR}/${DISTFILES} -d ${WRKSRC}
+
do-install:
- @${MKDIR} ${DATADIR}
- @${UNZIP_CMD} ${DISTDIR}/${DISTFILES} -d ${OADIR}
- @${CHMOD} -R o-w ${DATADIR}
+ ${MKDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${DATADIR})
.include "../openarena/Makefile.include"