aboutsummaryrefslogtreecommitdiff
path: root/games/rottdc/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/rottdc/files/Makefile')
-rw-r--r--games/rottdc/files/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/games/rottdc/files/Makefile b/games/rottdc/files/Makefile
new file mode 100644
index 000000000000..8c0405e42f75
--- /dev/null
+++ b/games/rottdc/files/Makefile
@@ -0,0 +1,13 @@
+# Makefile wrapper for building both full and shareware versions.
+#
+# $FreeBSD$
+#
+
+all: rott rott-sw
+ $(MAKE) -C rott
+ $(MAKE) -C rott-sw
+
+rott-sw:
+ cp -r rott rott-sw
+ sed -i '' -Ee 's|(SHAREWARE) *0|\1 1|' rott-sw/develop.h
+ sed -i '' -Ee 's|(SUPERROTT) *1|\1 1|' rott/develop.h