aboutsummaryrefslogtreecommitdiff
path: root/games/scourge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/scourge/Makefile')
-rw-r--r--games/scourge/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index c207ecc041f7..dd801db65e60 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scourge
-PORTVERSION= 0.11
+PORTVERSION= 0.13
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scourge
@@ -22,24 +22,24 @@ USE_SDL= sdl mixer net
USE_GMAKE= yes
USE_GCC= 3.3+
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_LIBS}
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-data-dir=${DATADIR}
-OPTIONS= DEBUG "Produce an executable with debugging symbols" off \
+OPTIONS= DEBUG "Produce an executable with debugging symbols" off
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
-post-install:
-.if !defined(NOPORTDOCS)
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/
@${MKDIR} ${DATADIR}
- @${CP} -R ${WRKSRC}/data/* ${DATADIR}
- @${FIND} ${DATADIR}/* -type f -print0 | \
- ${XARGS} -0 ${CHMOD} ${SHAREMODE}
-.endif
+ @cd ${WRKSRC}/data && \
+ ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
.include <bsd.port.mk>