aboutsummaryrefslogtreecommitdiff
path: root/games/sdlquake2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/sdlquake2/Makefile')
-rw-r--r--games/sdlquake2/Makefile55
1 files changed, 18 insertions, 37 deletions
diff --git a/games/sdlquake2/Makefile b/games/sdlquake2/Makefile
index 49d1f8c11ac3..6a057b5254ee 100644
--- a/games/sdlquake2/Makefile
+++ b/games/sdlquake2/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= http://koti.mbnet.fi/~turol/sdlquake2/
MAINTAINER= ports@FreeBSD.org
COMMENT= Combination of R1Q2 and R1GL with SDL code from Quake2Forge
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
OPTIONS_DEFINE= CLIENT DEDICATED GAME
OPTIONS_DEFAULT= CLIENT DEDICATED
@@ -21,57 +21,38 @@ CLIENT_DESC= Build client
DEDICATED_DESC= Build dedicated server
GAME_DESC= Build a main game .so file
+OPTIONS_SUB= yes
+
LIBDIR= ${PREFIX}/lib/${PORTNAME}
MAKE_ENV= LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR=${LIBDIR:S/${PREFIX}\///}
-NO_STAGE= yes
.include "${.CURDIR}/../quake2-data/Makefile.include"
-.include <bsd.port.options.mk>
+CLIENT_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
+CLIENT_USE= GL=yes
+CLIENT_USE= SDL=sdl
+CLIENT_MAKE_ENV= BUILD_CLIENT=YES
+CLIENT_CFLAGS= -I${LOCALBASE}/include/libpng15
-.if ${PORT_OPTIONS:MCLIENT}
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png
-USE_GL= yes
-USE_SDL= sdl
-MAKE_ENV+= BUILD_CLIENT=YES
-CFLAGS+= -I${LOCALBASE}/include/libpng15
-PLIST_SUB+= CLIENT=""
-.else
-PLIST_SUB+= CLIENT="@comment "
-.endif
+DEDICATED_MAKE_ENV= BUILD_DEDICATED=YES
-.if ${PORT_OPTIONS:MDEDICATED}
-MAKE_ENV+= BUILD_DEDICATED=YES
-PLIST_SUB+= DEDICATED=""
-.else
-PLIST_SUB+= DEDICATED="@comment "
-.endif
+GAME_MAKE_ENV= BUILD_GAME=YES
-.if ${PORT_OPTIONS:MGAME}
-MAKE_ENV+= BUILD_GAME=YES
-PLIST_SUB+= GAME=""
-.else
-PLIST_SUB+= GAME="@comment "
-.endif
+.include <bsd.port.options.mk>
do-install:
- ${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${STAGEDIR}${LIBDIR}/baseq2
.if ${PORT_OPTIONS:MCLIENT}
- ${INSTALL_PROGRAM} ${WRKSRC}/quake2 ${PREFIX}/bin/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/ref_sdlgl.so ${LIBDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/quake2 ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ref_sdlgl.so ${STAGEDIR}${LIBDIR}
.endif
.if ${PORT_OPTIONS:MDEDICATED}
- ${INSTALL_PROGRAM} ${WRKSRC}/q2ded ${PREFIX}/bin/${PORTNAME}-ded
+ ${INSTALL_PROGRAM} ${WRKSRC}/q2ded ${STAGEDIR}${PREFIX}/bin/${PORTNAME}-ded
.endif
.if ${PORT_OPTIONS:MGAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/baseq2/game.so ${LIBDIR}/baseq2
+ ${INSTALL_PROGRAM} ${WRKSRC}/baseq2/game.so ${STAGEDIR}${LIBDIR}/baseq2
.endif
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
-
.include <bsd.port.mk>