aboutsummaryrefslogtreecommitdiff
path: root/games/shaaft
diff options
context:
space:
mode:
Diffstat (limited to 'games/shaaft')
-rw-r--r--games/shaaft/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index 5cb1e8d20d56..3ba83418d93a 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -29,6 +29,12 @@ CONFIGURE_ARGS= --disable-optimize
MAN6= ${PORTNAME}.6
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= "Does not compile on sparc64"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG:T}|g ; \
s|^CXXFLAGS|#CXXFLAGS|g ; \
@@ -37,4 +43,4 @@ post-patch:
@${GREP} -lR "SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|SDL/SDL|SDL|g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>