aboutsummaryrefslogtreecommitdiff
path: root/games/smashbattle/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/smashbattle/Makefile')
-rw-r--r--games/smashbattle/Makefile31
1 files changed, 15 insertions, 16 deletions
diff --git a/games/smashbattle/Makefile b/games/smashbattle/Makefile
index 5f7f830f324b..72e4171c23a5 100644
--- a/games/smashbattle/Makefile
+++ b/games/smashbattle/Makefile
@@ -15,35 +15,34 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/battle/Battle
USE_ZIP= yes
EXTRACT_AFTER_ARGS= -d ${WRKDIR}/${DISTNAME}
-USES= gmake
+USES= dos2unix gmake
+DOS2UNIX_FILES= *.cpp *.h Makefile
USE_SDL= sdl image mixer
-USE_DOS2UNIX= *.cpp *.h *.ini Makefile
ALL_TARGET= battle
-NO_STAGE= yes
pre-extract:
@${MKDIR} ${WRKDIR}/${DISTNAME}
SUB_FILES= ${PORTNAME}
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} \
- -e 's|CC=|CC?=|' \
- -e 's|CFLAGS=-c -Wall|CFLAGS += $$(shell sdl-config --cflags) -c -Wall|' \
- -e 's|LDFLAGS=-lSDL -lSDL_mixer -lz -lstdc++|LDFLAGS += $$(shell $${SDL_CONFIG} --libs) -lSDL -lSDL_mixer -lz -lstdc++ -lm|' \
+ -e 's|CC=|CC?=| ; \
+ s|CFLAGS=-c -Wall|CFLAGS += $$(shell sdl-config --cflags) -c -w| ; \
+ s|LDFLAGS=-lSDL -lSDL_mixer -lz -lstdc++|LDFLAGS += $$(shell $${SDL_CONFIG} --libs) -lSDL -lSDL_mixer -lz -lstdc++ -lm|' \
${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|/usr/share/games/smashbattle/gfx/SB.png|${PORTNAME}|' \
- -e 's|/usr/local/bin/smashbattle|${PORTNAME}|' \
+ @${REINPLACE_CMD} -e 's|/usr/share/games/smashbattle/gfx/SB.png|${PORTNAME}| ; \
+ s|/usr/local/bin/smashbattle|${PORTNAME}|' \
${WRKSRC}/linux/*.desktop
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} "gfx music sfx stage" ${DATADIR})
- ${INSTALL_PROGRAM} ${WRKSRC}/battle ${DATADIR}/${PORTNAME}
- ${LN} -sf ${DATADIR}/gfx/SB.png ${PREFIX}/share/pixmaps/${PORTNAME}.png
-# ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${PREFIX}/share/applications/
- ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${DESKTOPDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+.for d in gfx music sfx stage
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
+.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/battle ${STAGEDIR}${DATADIR}/${PORTNAME}
+ ${LN} -sf ${DATADIR}/gfx/SB.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_DATA} ${WRKSRC}/linux/*.desktop ${STAGEDIR}${DESKTOPDIR}
.include <bsd.port.mk>