aboutsummaryrefslogtreecommitdiff
path: root/games/warsow-data/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/warsow-data/Makefile')
-rw-r--r--games/warsow-data/Makefile36
1 files changed, 25 insertions, 11 deletions
diff --git a/games/warsow-data/Makefile b/games/warsow-data/Makefile
index 0b2a0f3bc727..5dc579250d13 100644
--- a/games/warsow-data/Makefile
+++ b/games/warsow-data/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: warsow-data
+# New ports collection makefile for: Warsow game data
# Date created: 2006-08-03
# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
#
@@ -6,17 +6,17 @@
#
PORTNAME= data
-PORTVERSION= 0.42
+PORTVERSION= 0.5
CATEGORIES= games
-MASTER_SITES= http://data.rodix.free.fr/warsow/files/ \
- http://88.191.19.21/wsw/ \
- http://www.derchris.net/warsow/ \
- http://gedankenschlag.de/mirror/ \
- http://uzz.cc/ \
- http://wahs.de/warsow/ \
- http://tastyspleen.net/quake/downloads/mods/warsow/
+MASTER_SITES= http://woe.crying-wolves.net/ \
+ http://www.derchris.eu/warsow/ \
+ http://warsow.hangy.de/ \
+ http://static.warsow.net/release/ \
+ http://rewq.de/scratch/wsw05/ \
+ http://weseo.de/downloads/
PKGNAMEPREFIX= warsow-
DISTNAME= ${PKGNAMEPREFIX:S/-//}_${PORTVERSION}_unified
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= ${PKGNAMEPREFIX:S/-//}
MAINTAINER= acm@FreeBSD.org
@@ -24,20 +24,34 @@ COMMENT= Warsow data files
ONLY_FOR_ARCHS= i386 amd64
USE_ZIP= yes
-USE_DOS2UNIX= ${TXTDOCS}
NO_BUILD= yes
+NO_WRKSUBDIR= yes
DATADIR= ${PREFIX}/share/${PKGNAMEPREFIX:S/-//}
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX:S/-//}
-TXTDOCS= bots_navigation.txt changelog.txt contact.txt credits.txt \
+TXTDOCS= bots_navigation.txt changelog.txt contact.txt \
dedicated_server_quide.txt demoavi.txt democams.txt \
features.txt huds.txt license.txt mousefilter.txt \
query_protocols.txt
PORTDOCS= 0.4_renderer_changes.png ${TXTDOCS}
+OPTIONS= MAPPACK "Install community map pack" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_MAPPACK)
+DISTFILES+= warsow_comunity_map_pack_01${EXTRACT_SUFX}
+PLIST_SUB+= MAPPACK=""
+.else
+PLIST_SUB+= MAPPACK="@comment "
+.endif
+
do-install:
@${MKDIR} ${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} basewsw ${DATADIR}
+.if defined(WITH_MAPPACK)
+ cd ${WRKSRC} && ${COPYTREE_SHARE} previews ${DATADIR}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}