aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/openspades/Makefile5
-rw-r--r--games/phlipple/Makefile5
-rw-r--r--games/scorched3d/Makefile5
-rw-r--r--games/warzone2100/Makefile3
4 files changed, 7 insertions, 11 deletions
diff --git a/games/openspades/Makefile b/games/openspades/Makefile
index aeb1eff0d118..6baef7a858cb 100644
--- a/games/openspades/Makefile
+++ b/games/openspades/Makefile
@@ -16,8 +16,7 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick # for building icons
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libGLEW.so:${PORTSDIR}/graphics/glew
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
BROKEN_FreeBSD_9= does not build on FreeBSD 9.x
@@ -30,7 +29,7 @@ CMAKE_ARGS= -DOPENSPADES_RESOURCES=OFF \
-DOPENSPADES_INSTALL_BINARY="bin" \
-DOPENSPADES_INSTALL_RESOURCES="${DATADIR_REL}"
USE_SDL= sdl2 image2
-USE_GL= gl
+USE_GL= gl glew
INSTALLS_ICONS= yes
PORTDOCS= *
diff --git a/games/phlipple/Makefile b/games/phlipple/Makefile
index 60af5baa7022..074c5d59b842 100644
--- a/games/phlipple/Makefile
+++ b/games/phlipple/Makefile
@@ -11,12 +11,11 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Flipping squares will never be the same
LIB_DEPENDS= libogg.so:${PORTSDIR}/audio/libogg \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
- libGLEW.so:${PORTSDIR}/graphics/glew
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
USES= desktop-file-utils pkgconfig
USE_SDL= sdl mixer image
-USE_GL= gl glu
+USE_GL= gl glew glu
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index cb5041ae01f3..070f1b84555f 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -13,8 +13,7 @@ COMMENT= 3D version of the classic DOS game Scorched Earth
LICENSE= GPLv2
-LIB_DEPENDS= libGLEW.so:${PORTSDIR}/graphics/glew \
- libvorbis.so:${PORTSDIR}/audio/libvorbis \
+LIB_DEPENDS= libvorbis.so:${PORTSDIR}/audio/libvorbis \
libpng.so:${PORTSDIR}/graphics/png \
libfftw3.so:${PORTSDIR}/math/fftw3 \
libfftw3f.so:${PORTSDIR}/math/fftw3-float \
@@ -24,7 +23,7 @@ OPTIONS_DEFINE= MYSQL
WRKSRC= ${WRKDIR}/scorched
-USE_GL= glu
+USE_GL= glew glu
USE_SDL= mixer net sdl
USE_WX= 2.8
WX_CONF_ARGS= absolute
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index d77eb4947e9c..ae08cf59ded6 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
libpng.so:${PORTSDIR}/graphics/png \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libtheora.so:${PORTSDIR}/multimedia/libtheora \
- libGLEW.so:${PORTSDIR}/graphics/glew \
libfribidi.so:${PORTSDIR}/converters/fribidi \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
@@ -25,7 +24,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-font
USES= tar:xz bison gmake openal:al pkgconfig compiler:c++11-lang # actually, old gcc fails on unknown -W flag
GNU_CONFIGURE= yes
-USE_GL= yes
+USE_GL= glew glu
USE_SDL= sdl
USE_QT4= corelib network script gui moc_build
QT_NONSTANDARD= yes