aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/blobby/Makefile8
-rw-r--r--games/cosmosmash/Makefile2
-rw-r--r--games/flightgear-data/Makefile6
-rw-r--r--games/flightgear-mb339-pan/Makefile4
-rw-r--r--games/flightgear/Makefile6
-rw-r--r--games/jfsw/Makefile6
-rw-r--r--games/openalchemist/Makefile6
7 files changed, 20 insertions, 18 deletions
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index 17c8ad4b700d..742eb577b245 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -15,14 +15,14 @@ COMMENT= Official continuation of the famous Blobby Volley 1.x game
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libphysfs.so:devel/physfs
-BUILD_DEPENDS= zip:archivers/zip \
- ${LOCALBASE}/include/boost/crc.hpp:devel/boost-libs
-
BROKEN_powerpc64= fails to build: cc1plus: unrecognized command line option "-std=c++11"
NOT_FOR_ARCHS= aarch64
NOT_FOR_ARCHS_REASON= fails to compile: I can't tell what endian-ness to use for your architecture
+LIB_DEPENDS= libphysfs.so:devel/physfs
+BUILD_DEPENDS= zip:archivers/zip \
+ ${LOCALBASE}/include/boost/crc.hpp:devel/boost-libs
+
USES= cmake dos2unix localbase:ldflags pkgconfig
DOS2UNIX_REGEX= .*\.(c|h|cpp)
CMAKE_ARGS= -DDATADIR:PATH="${DATADIR}"
diff --git a/games/cosmosmash/Makefile b/games/cosmosmash/Makefile
index 2f53284d85e6..7ec7d148458d 100644
--- a/games/cosmosmash/Makefile
+++ b/games/cosmosmash/Makefile
@@ -18,9 +18,9 @@ LIB_DEPENDS= libflatzebra-0.1.so:devel/flatzebra \
libmikmod.so:audio/libmikmod \
libaudiofile.so:audio/libaudiofile
+USES= iconv pkgconfig desktop-file-utils
USE_SDL= sdl image mixer
USE_XORG= x11 xau xdmcp
-USES= iconv pkgconfig desktop-file-utils
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
LDFLAGS+= -lpthread -L${LOCALBASE}/lib `${SDL_CONFIG} --libs`
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index ac1fedc008b2..62314c729d68 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -12,6 +12,9 @@ COMMENT= FlightGear scenery, textures, and aircraft models
LICENSE= GPLv2
+BROKEN_aarch64= Fails to install: runaway process
+BROKEN_mips64= Fails to install: runaway process
+
NO_BUILD= yes
USES= tar:bzip2
WRKSRC= ${WRKDIR}/fgdata
@@ -20,9 +23,6 @@ DATADIR= ${PREFIX}/share/flightgear
PLIST= ${WRKDIR}/pkg-plist
PLIST_DIRS= %%DATADIR%%
-BROKEN_aarch64= Fails to install: runaway process
-BROKEN_mips64= Fails to install: runaway process
-
post-patch:
@${RM} ${WRKSRC}/COPYING
diff --git a/games/flightgear-mb339-pan/Makefile b/games/flightgear-mb339-pan/Makefile
index 9aa76563fd4c..d1eb593f9ff1 100644
--- a/games/flightgear-mb339-pan/Makefile
+++ b/games/flightgear-mb339-pan/Makefile
@@ -11,12 +11,12 @@ DISTNAME= mb339pan_${PORTVERSION}
MAINTAINER= martymac@FreeBSD.org
COMMENT= Simulation of the MB-339 PAN aerobatic jet
+BROKEN_powerpc64= fails to build: runaway process
+
RUN_DEPENDS= ${LOCALBASE}/share/flightgear/version:games/flightgear-data
RESTRICTED= Redistribution prohibited
-BROKEN_powerpc64= fails to build: runaway process
-
NO_BUILD= yes
USES= zip
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 4d71ee35b3e4..7e4904ba6ad1 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= games
MASTER_SITES= SF/flightgear/release-${PORTVERSION:R}
MAINTAINER= martymac@FreeBSD.org
-COMMENT= The FlightGear flight simulator
+COMMENT= FlightGear flight simulator
LICENSE= GPLv2
@@ -27,11 +27,11 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:x11-toolkits/plib \
${LOCALBASE}/lib/libSimGearCore.a:devel/simgear \
${LOCALBASE}/share/flightgear/version:games/flightgear-data
+USES= alias cmake compiler cpe dos2unix jpeg openal:al,alut sqlite \
+ tar:bzip2
USE_XORG= ice sm x11 xext xft xi xinerama xmu xt
USE_GL= gl glew glu glut
-USES= alias cmake compiler cpe dos2unix jpeg openal:al,alut sqlite \
- tar:bzip2
DOS2UNIX_REGEX= .*\.(c|h|cxx|cpp|hxx|hpp)
CMAKE_ARGS+= -DENABLE_JS_SERVER:BOOL=ON \
-DSYSTEM_SQLITE:BOOL=ON \
diff --git a/games/jfsw/Makefile b/games/jfsw/Makefile
index 1cf0be56e38f..2bfcf2dbaf1e 100644
--- a/games/jfsw/Makefile
+++ b/games/jfsw/Makefile
@@ -17,6 +17,9 @@ LICENSE_PERMS_BuildLic= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-acc
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
+USES= alias dos2unix gmake pkgconfig:build
+DOS2UNIX_REGEX= .*(\.(c|h)|Makefile)(\.deps)?
+
USE_GITHUB= yes
GH_ACCOUNT= jonof
GH_PROJECT= jfbuild:build jfaudiolib:audio jfmact:mact
@@ -30,9 +33,6 @@ USE_GL= gl
USE_GNOME= gtk20
USE_SDL= mixer sdl
-USES= alias dos2unix gmake pkgconfig:build
-DOS2UNIX_REGEX= .*(\.(c|h)|Makefile)(\.deps)?
-
NO_CDROM= Must be distributed only through the Internet and free of charge
MAKE_ENV+= DATADIR="${DATADIR}" \
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 597f29f10b25..6c8ef6a34785 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -22,12 +22,14 @@ LIB_DEPENDS= libclanCore.so:devel/clanlib1 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
+
+USES= autoreconf gmake iconv jpeg pkgconfig python:2.7,run shebangfix
+SHEBANG_FILES= openalchemist-config
+
USE_GNOME= pygtk2
USE_XORG= xxf86vm xi x11 xmu xext xdamage xfixes xau xdmcp xt sm ice
USE_GL= gl glu
USE_SDL= sdl gfx
-USES= autoreconf gmake iconv jpeg pkgconfig python:2.7,run shebangfix
-SHEBANG_FILES= openalchemist-config
PORTDOCS= AUTHORS ChangeLog README TODO