aboutsummaryrefslogtreecommitdiff
path: root/graphics/azpainter
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/azpainter')
-rw-r--r--graphics/azpainter/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/graphics/azpainter/Makefile b/graphics/azpainter/Makefile
index c9779f12b01e..abe0554c4c54 100644
--- a/graphics/azpainter/Makefile
+++ b/graphics/azpainter/Makefile
@@ -15,8 +15,6 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png
-BROKEN_powerpc64= fails to build: mListDef.h: redefinition of typedef 'mList'
-
USES= desktop-file-utils jpeg localbase shared-mime-info tar:xz
USE_XORG= x11 xext xi
GNU_CONFIGURE= yes
@@ -27,6 +25,12 @@ PORTDOCS= AUTHORS ChangeLog NEWS README README_ja manual
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
+.include <bsd.port.pre.mk>
+
+.if ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
+USE_GCC= yes
+.endif
+
post-patch-NLS-off:
@${REINPLACE_CMD} -e 's, install-dist_trdataDATA$$,,' \
${WRKSRC}/data/Makefile.in
@@ -41,4 +45,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -a ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>