aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-igeoportal/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/deegree-igeoportal/Makefile')
-rw-r--r--graphics/deegree-igeoportal/Makefile41
1 files changed, 28 insertions, 13 deletions
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index 9c40f70752a9..9937369fc6cd 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -1,4 +1,4 @@
-# Created by: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
@@ -13,36 +13,51 @@ DISTNAME= ${PORTNAME}-std_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Browser based client handling WMS, WFS, and proxy service
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
-
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
+APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
-PORTDOCS= *
+PORTDOCS= README.txt README_owswatch.txt deegree_igeoportal_documentation_en.pdf
DOCSDIR= ${PREFIX}/share/doc/deegree-igeoportal
PLIST_SUB= TOMCATDIR=${TOMCATDIR:S|^${PREFIX}/||}
+SUB_FILES= pkg-message
+SUB_LIST= TCPORT=${TCPORT}
+
+OPTIONS_SINGLE= AS
+OPTIONS_SINGLE_AS= TOMCAT6 TOMCAT7
+OPTIONS_DEFAULT= TOMCAT6
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MTOMCAT6}
+TOMCATVER= apache-tomcat-6.0
+TCPORT= 8180
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
+.endif
+
+.if ${PORT_OPTIONS:MTOMCAT7}
+TOMCATVER= apache-tomcat-7.0
+TCPORT= 8080
+BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
+.endif
post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/igeoportal-std.war -C ${WRKDIR}/${PORTDIRNAME}
-.include <bsd.port.options.mk>
-
do-install:
- ${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
- @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
+ ${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
+ @cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/deegree_igeoportal_documentation_en.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${DOCSDIR}
.endif
-
-post-install:
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>