aboutsummaryrefslogtreecommitdiff
path: root/graphics/deegree-wpvs
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/deegree-wpvs')
-rw-r--r--graphics/deegree-wpvs/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/graphics/deegree-wpvs/Makefile b/graphics/deegree-wpvs/Makefile
index 0934519c45fa..78cfda982f58 100644
--- a/graphics/deegree-wpvs/Makefile
+++ b/graphics/deegree-wpvs/Makefile
@@ -12,10 +12,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Deegree Web Terrain Service(WTS)/Web Perspective View Service(WPVS)
+LICENSE= LGPL21+
+
USES= zip
USE_JAVA= 1.6+
NO_BUILD= yes
+NO_ARCH= yes
TOMCATDIR= ${PREFIX}/${TOMCATVER}
APPHOME= ${LOCALBASE}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
@@ -34,14 +37,14 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MTOMCAT6}
TOMCATVER= apache-tomcat-6.0
-TCPORT= 8180
+TCPORT= 8180
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
.endif
.if ${PORT_OPTIONS:MTOMCAT7}
TOMCATVER= apache-tomcat-7.0
-TCPORT= 8080
+TCPORT= 8080
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
.endif
@@ -51,9 +54,11 @@ post-extract:
@${TAR} xf ${WRKDIR}/deegree-wpvs.war -C ${WRKDIR}/${PORTDIRNAME}
do-install:
- ${INSTALL} -d ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ @${MKDIR} ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>