aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-loader-generic/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/evas-loader-generic/Makefile')
-rw-r--r--graphics/evas-loader-generic/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/graphics/evas-loader-generic/Makefile b/graphics/evas-loader-generic/Makefile
deleted file mode 100644
index 62e7b28d26b3..000000000000
--- a/graphics/evas-loader-generic/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# Created by: Grzegorz Blach <gblach@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= loader-generic
-PORTVERSION= 1.7.9
-CATEGORIES= graphics enlightenment
-MASTER_SITES= http://download.enlightenment.org/releases/ \
- LOCAL/gblach/e17/
-PKGNAMEPREFIX= evas-
-DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
-
-MAINTAINER= gblach@FreeBSD.org
-COMMENT= Hardware accelerated canvas API (generic loader)
-
-LICENSE= BSD
-
-EVAS_GENERIC_LOADERS= gst pdf ps raw svg xcf
-
-.for NODE in ${EVAS_GENERIC_LOADERS}
-OPTIONS_DEFINE+= ${NODE:tu}
-OPTIONS_DEFAULT+= ${NODE:tu}
-${NODE:tu}_DESC= Install ${NODE} evas generic loader
-.endfor
-
-DIST_SUBDIR= e17
-GNU_CONFIGURE= yes
-USES= gmake pkgconfig tar:bzip2
-USE_EFL= evas librt_hack libtool_hack
-USE_LDCONFIG= yes
-
-MAKEDIRS= ${WRKSRC}/src/modules/loaders/generic
-
-.include "../evas-core/Makefile.inc"
-CONFIGURE_ARGS+= --enable-image-loader-generic
-
-.include <bsd.port.options.mk>
-
-.for NODE in ${EVAS_GENERIC_LOADERS}
-. if ${PORT_OPTIONS:M${NODE:tu}}
-RUN_DEPENDS+= ${LOCALBASE}/lib/evas/utils/evas_image_loader.${NODE}:${PORTSDIR}/graphics/evas_generic_loaders-${NODE}
-. endif
-.endfor
-
-post-patch:
- @${REINPLACE_CMD} -E \
- -e 's,\$$\(top_builddir\)/src/lib/\.libs,${LOCALBASE}/lib,' \
- -e 's,\$$\(top_builddir\)/src/lib/libevas\.la,-levas,' \
- ${MAKEDIRS:S,$,/Makefile.in,}
-
-do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
-
-do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
-
-.include <bsd.port.mk>