aboutsummaryrefslogtreecommitdiff
path: root/graphics/evas-loader-pmaps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/evas-loader-pmaps/Makefile')
-rw-r--r--graphics/evas-loader-pmaps/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/graphics/evas-loader-pmaps/Makefile b/graphics/evas-loader-pmaps/Makefile
deleted file mode 100644
index 4ca24e928565..000000000000
--- a/graphics/evas-loader-pmaps/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# Created by: Grzegorz Blach <gblach@FreeBSD.org>
-# $FreeBSD$
-
-PORTNAME= loader-pmaps
-PORTVERSION= 1.7.9
-CATEGORIES= graphics enlightenment
-MASTER_SITES= http://download.enlightenment.org/releases/ \
- LOCAL/gblach/e17/
-PKGNAMEPREFIX= evas-
-DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
-
-MAINTAINER= gblach@FreeBSD.org
-COMMENT= Hardware accelerated canvas API (PMAPS loader)
-
-LICENSE= BSD
-
-DIST_SUBDIR= e17
-GNU_CONFIGURE= yes
-USES= gmake pkgconfig tar:bzip2
-USE_EFL= evas librt_hack libtool_hack
-USE_LDCONFIG= yes
-
-MAKEDIRS= ${WRKSRC}/src/modules/loaders/pmaps
-
-.include "../evas-core/Makefile.inc"
-CONFIGURE_ARGS+= --enable-image-loader-pmaps
-
-post-patch:
- @${REINPLACE_CMD} -E \
- -e 's,\$$\(top_builddir\)/src/lib/\.libs,${LOCALBASE}/lib,' \
- -e 's,\$$\(top_builddir\)/src/lib/libevas\.la,-levas,' \
- ${MAKEDIRS:S,$,/Makefile.in,}
-
-do-build:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}; done)
-
-do-install:
- @(for DIR in ${MAKEDIRS}; do cd $${DIR}; ${SETENV} ${MAKE_ENV} ${MAKE_CMD} \
- ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}; done)
-
-.include <bsd.port.mk>