aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeglut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/freeglut/Makefile')
-rw-r--r--graphics/freeglut/Makefile23
1 files changed, 7 insertions, 16 deletions
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index cd16a042dcbf..87e744925033 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -7,23 +7,25 @@
#
PORTNAME= freeglut
-PORTVERSION= 2.6.0
+PORTVERSION= 2.8.0
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}/
+MASTER_SITES= SF
MAINTAINER= graudeejs@gmail.com
COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
+LICENSE= MIT
+
CONFLICTS= libglut-[0-9].*
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_XORG= ice xi
+USE_XORG= ice xi xxf86vm xrandr
USE_GL= glu
CONFIGURE_ARGS= --disable-warnings
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lusbhid
+LDFLAGS+= -L${LOCALBASE}/lib -lusbhid
USE_LDCONFIG= yes
DOCS= download.html freeglut.html freeglut_logo.png \
@@ -31,12 +33,6 @@ DOCS= download.html freeglut.html freeglut_logo.png \
progress.html structure.html
BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 800000
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-src__freeglut_joystick.c
-.endif
-
pre-configure:
.for fract in Fractals/fractals.c Fractals_random/fractals_random.c
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
@@ -63,10 +59,5 @@ post-install:
.endfor
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
-.if ${OSVERSION} >= 800000
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>