aboutsummaryrefslogtreecommitdiff
path: root/graphics/gstreamer-plugins-gl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gstreamer-plugins-gl/Makefile')
-rw-r--r--graphics/gstreamer-plugins-gl/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/gstreamer-plugins-gl/Makefile b/graphics/gstreamer-plugins-gl/Makefile
index e89cc8d2fe0b..39e862282c1e 100644
--- a/graphics/gstreamer-plugins-gl/Makefile
+++ b/graphics/gstreamer-plugins-gl/Makefile
@@ -11,8 +11,8 @@ DISTNAME= ${PORTNAME:S/gstreamer/gst/}-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= GStreamer OpenGL video plugin
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_BZIP2= yes
USE_LDCONFIG= yes
@@ -27,5 +27,8 @@ CONFIGURE_ARGS=--disable-examples
PLIST_SUB= VERSION="0.10"
-NO_STAGE= yes
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgstgl-0.10.so.1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gstreamer-0.10/libgst*.so
+
.include <bsd.port.mk>