aboutsummaryrefslogtreecommitdiff
path: root/graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt')
-rw-r--r--graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt b/graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt
new file mode 100644
index 000000000000..f2154559660e
--- /dev/null
+++ b/graphics/ilmbase/files/patch-IlmThread__CMakeLists.txt
@@ -0,0 +1,19 @@
+--- IlmThread/CMakeLists.txt.orig 2013-11-12 01:10:49.000000000 +0400
++++ IlmThread/CMakeLists.txt 2014-03-27 00:38:30.616700075 +0400
+@@ -18,6 +18,7 @@
+ )
+ ENDIF()
+
++FIND_PACKAGE(Threads)
+
+ IF(BUILD_SHARED_LIBS)
+ ADD_DEFINITIONS(-DILMTHREAD_EXPORTS)
+@@ -26,7 +27,7 @@
+ ADD_LIBRARY ( IlmThread ${LIB_TYPE}
+ ${ILMTHREAD_LIBRARY_SOURCES}
+ )
+-TARGET_LINK_LIBRARIES(IlmThread Iex)
++TARGET_LINK_LIBRARIES(IlmThread Iex ${CMAKE_THREAD_LIBS_INIT})
+
+ INSTALL ( TARGETS
+ IlmThread